summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD60
-rw-r--r--fix-missing-header.patch11
3 files changed, 58 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b473de031aa0..6088fceb6cae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,26 @@
pkgbase = ewebkit
pkgdesc = WebKit ported to the Enlightenment Foundation Libraries
- pkgver = 1.11.0
- pkgrel = 2
- url = http://trac.webkit.org/wiki/EFLWebKit
+ pkgver = 1.18
+ pkgrel = 1
+ url = http://ewebkit.org/
arch = i686
arch = x86_64
- license = LGPL2
- license = LGPL2.1
- license = BSD
+ license = custom
makedepends = cmake
- makedepends = perl
- makedepends = python2
- makedepends = ruby
makedepends = gperf
+ makedepends = python
+ makedepends = ruby
depends = atk
- depends = cairo
depends = efl
depends = enchant
depends = harfbuzz-icu
+ depends = hyphen
depends = libsoup
depends = libxslt
- source = http://download.enlightenment.org/rel/libs/webkit-efl/ewebkit-1.11.0.tar.xz
- sha256sums = d8d21e27f4a21cd77c41914548c184ddb98693ba23851aa66c8e51c0be4b90b7
+ source = https://download.enlightenment.org/rel/libs/webkit-efl/ewebkit-1.18.tar.xz
+ source = fix-missing-header.patch
+ sha256sums = 02088758f67fb8e7031bd16e6d871bb4225e62e6de37a2ab408346ab0c45fd72
+ sha256sums = 7507216f5a21325602bbb950247f99fb2755a02ceb4bca0ab3a8ebb24403793a
pkgname = ewebkit
diff --git a/PKGBUILD b/PKGBUILD
index fb55630058cd..896618abb311 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,42 +2,54 @@
# Contributor: twa022 <twa022 at gmail dot com>
pkgname=ewebkit
-pkgver=1.11.0
-pkgrel=2
+pkgver=1.18
+pkgrel=1
pkgdesc="WebKit ported to the Enlightenment Foundation Libraries"
arch=('i686' 'x86_64')
-url="http://trac.webkit.org/wiki/EFLWebKit"
-license=('LGPL2' 'LGPL2.1' 'BSD')
-depends=('atk' 'cairo' 'efl' 'enchant' 'harfbuzz-icu' 'libsoup' 'libxslt')
-makedepends=('cmake' 'perl' 'python2' 'ruby' 'gperf')
-source=("http://download.enlightenment.org/rel/libs/webkit-efl/$pkgname-$pkgver.tar.xz")
-sha256sums=('d8d21e27f4a21cd77c41914548c184ddb98693ba23851aa66c8e51c0be4b90b7')
+url="http://ewebkit.org/"
+license=('custom')
+depends=('atk' 'efl' 'enchant' 'harfbuzz-icu' 'hyphen' 'libsoup' 'libxslt')
+makedepends=('cmake' 'gperf' 'python' 'ruby')
+source=("https://download.enlightenment.org/rel/libs/webkit-efl/$pkgname-$pkgver.tar.xz"
+ "fix-missing-header.patch")
+sha256sums=('02088758f67fb8e7031bd16e6d871bb4225e62e6de37a2ab408346ab0c45fd72'
+ '7507216f5a21325602bbb950247f99fb2755a02ceb4bca0ab3a8ebb24403793a')
prepare() {
-# Turn off -Werror, causes too many build failures for things we don't care about
- sed -i '/-Werror/d' $pkgname/Source/cmake/WebKitHelpers.cmake
+ mkdir build
+ cd $pkgname
+
+ # Fix missing header
+ patch -Np1 -i ../fix-missing-header.patch
-# Build with glib 2.43+
- sed -i '/^\s\?\+GMutexLocker/ s/GMutexLocker/WebCore::GMutexLocker/' \
- $pkgname/Source/WebCore/platform/graphics/gstreamer/{WebKitWebSourceGStreamer.cpp,MediaPlayerPrivateGStreamerBase.cpp,VideoSinkGStreamer.cpp}
+ # Turn off -Werror, causes too many build failures for things we don't care about
+ sed -i '/-Werror/d' Source/cmake/WebKitHelpers.cmake
}
build() {
- cd $pkgname
-
- cmake . \
+ cd build
+ export LDFLAGS="$LDFLAGS -lpthread"
+ cmake ../$pkgname \
+ -DPORT=Efl \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_SKIP_RPATH=ON \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DENABLE_TOOLS=OFF
-
- make
+ -DLIB_INSTALL_DIR=/usr/lib \
+ -DLIBEXEC_INSTALL_DIR=/usr/lib/$pkgname \
+ -DENABLE_GEOLOCATION=OFF \
+ -DENABLE_SPEECH_SYNTHESIS=OFF
+ make -j8
}
package() {
- cd $pkgname
-
+ cd build
make DESTDIR="$pkgdir" install
-# install license files
- install -d "$pkgdir/usr/share/licenses/$pkgname/"
- install -m644 Source/WebCore/LICENSE-{APPLE,LGPL-2} "$pkgdir/usr/share/licenses/$pkgname/"
+ install -m755 -d "$pkgdir/usr/share/licenses/$pkgname"
+ cd "$srcdir/$pkgname/Source"
+ for f in $(find -name 'COPYING*' -or -name 'LICENSE*'); do
+ echo $f >> "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cat $f >> "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ echo "" >> "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ done
}
diff --git a/fix-missing-header.patch b/fix-missing-header.patch
new file mode 100644
index 000000000000..7914e5690676
--- /dev/null
+++ b/fix-missing-header.patch
@@ -0,0 +1,11 @@
+diff -Naur ewebkit.orig/Source/WebKit2/PlatformEfl.cmake ewebkit/Source/WebKit2/PlatformEfl.cmake
+--- ewebkit.orig/Source/WebKit2/PlatformEfl.cmake 2016-08-04 15:31:20.000000000 +0200
++++ ewebkit/Source/WebKit2/PlatformEfl.cmake 2016-10-16 14:58:56.063561199 +0200
+@@ -402,6 +402,7 @@
+ "${CMAKE_CURRENT_SOURCE_DIR}/UIProcess/API/efl/ewk_url_response.h"
+ "${CMAKE_CURRENT_SOURCE_DIR}/UIProcess/API/efl/ewk_url_scheme_request.h"
+ "${CMAKE_CURRENT_SOURCE_DIR}/UIProcess/API/efl/ewk_view.h"
++ "${CMAKE_CURRENT_SOURCE_DIR}/UIProcess/API/efl/ewk_view_configuration.h"
+ "${CMAKE_CURRENT_SOURCE_DIR}/UIProcess/API/efl/ewk_window_features.h"
+ )
+