summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--0001-remove-box_syntax.patch60
-rw-r--r--PKGBUILD14
4 files changed, 75 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbaba95ab63c..61633ec6daf2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = eww-wayland-git
pkgdesc = ElKowar's wacky widgets (Wayland build)
- pkgver = 0.4.0.r20.g8ff4142
+ pkgver = 0.4.0.r21.g45154bb
pkgrel = 1
url = https://github.com/elkowar/eww
install = eww-wayland-git.install
@@ -13,8 +13,10 @@ pkgbase = eww-wayland-git
provides = eww=0.4.0
conflicts = eww
source = git+https://github.com/elkowar/eww.git?signed
+ source = 0001-remove-box_syntax.patch
validpgpkeys = B558974128820CB473BD9807E321AD71B1D1F27F
validpgpkeys = 5DE3E0509C47EA3CF04A42D34AEE18F83AFDEB23
b2sums = SKIP
+ b2sums = 2953945ff2286fef89c5a08e834221b15900ef43c5422871e247ff5b6c13983f5c7a3869ae9dcc670809b10f921c6d4b822c77d07033bf36d7bf1d285589de20
pkgname = eww-wayland-git
diff --git a/.gitignore b/.gitignore
index a8b40289b59d..1027924a04fc 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@
!/.SRCINFO
!/PKGBUILD
!/eww-wayland-git.install
+!/*.patch
diff --git a/0001-remove-box_syntax.patch b/0001-remove-box_syntax.patch
new file mode 100644
index 000000000000..e6f8088fa20e
--- /dev/null
+++ b/0001-remove-box_syntax.patch
@@ -0,0 +1,60 @@
+From d0dc1750f0e5c1693852ba6d954eb3b9f2985d86 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?=C3=A9clairevoyant?=
+ <848000+eclairevoyant@users.noreply.github.com>
+Date: Sat, 18 Mar 2023 02:02:23 -0400
+Subject: [PATCH] remove box_syntax
+
+---
+ crates/eww/src/main.rs | 1 -
+ crates/simplexpr/src/eval.rs | 8 ++++----
+ crates/simplexpr/src/lib.rs | 1 -
+ 3 files changed, 4 insertions(+), 6 deletions(-)
+
+diff --git a/crates/eww/src/main.rs b/crates/eww/src/main.rs
+index 8e51a62..14bc819 100644
+--- a/crates/eww/src/main.rs
++++ b/crates/eww/src/main.rs
+@@ -1,6 +1,5 @@
+ #![feature(trace_macros)]
+ #![feature(drain_filter)]
+-#![feature(box_syntax)]
+ #![feature(box_patterns)]
+ #![feature(slice_concat_trait)]
+ #![feature(try_blocks)]
+diff --git a/crates/simplexpr/src/eval.rs b/crates/simplexpr/src/eval.rs
+index d0b4811..76f811d 100644
+--- a/crates/simplexpr/src/eval.rs
++++ b/crates/simplexpr/src/eval.rs
+@@ -93,14 +93,14 @@ impl SimplExpr {
+ pub fn try_map_var_refs<E, F: Fn(Span, VarName) -> Result<SimplExpr, E> + Copy>(self, f: F) -> Result<Self, E> {
+ use SimplExpr::*;
+ Ok(match self {
+- BinOp(span, box a, op, box b) => BinOp(span, box a.try_map_var_refs(f)?, op, box b.try_map_var_refs(f)?),
++ BinOp(span, box a, op, box b) => BinOp(span, Box::new(a.try_map_var_refs(f)?), op, Box::new(b.try_map_var_refs(f)?)),
+ Concat(span, elems) => Concat(span, elems.into_iter().map(|x| x.try_map_var_refs(f)).collect::<Result<_, _>>()?),
+- UnaryOp(span, op, box a) => UnaryOp(span, op, box a.try_map_var_refs(f)?),
++ UnaryOp(span, op, box a) => UnaryOp(span, op, Box::new(a.try_map_var_refs(f)?)),
+ IfElse(span, box a, box b, box c) => {
+- IfElse(span, box a.try_map_var_refs(f)?, box b.try_map_var_refs(f)?, box c.try_map_var_refs(f)?)
++ IfElse(span, Box::new(a.try_map_var_refs(f)?), Box::new(b.try_map_var_refs(f)?), Box::new(c.try_map_var_refs(f)?))
+ }
+ JsonAccess(span, safe, box a, box b) => {
+- JsonAccess(span, safe, box a.try_map_var_refs(f)?, box b.try_map_var_refs(f)?)
++ JsonAccess(span, safe, Box::new(a.try_map_var_refs(f)?), Box::new(b.try_map_var_refs(f)?))
+ }
+ FunctionCall(span, name, args) => {
+ FunctionCall(span, name, args.into_iter().map(|x| x.try_map_var_refs(f)).collect::<Result<_, _>>()?)
+diff --git a/crates/simplexpr/src/lib.rs b/crates/simplexpr/src/lib.rs
+index 205b298..8a40287 100644
+--- a/crates/simplexpr/src/lib.rs
++++ b/crates/simplexpr/src/lib.rs
+@@ -1,6 +1,5 @@
+ #![feature(box_patterns)]
+ #![feature(pattern)]
+-#![feature(box_syntax)]
+ #![feature(try_blocks)]
+ #![feature(unwrap_infallible)]
+ #![feature(never_type)]
+--
+2.39.2
+
diff --git a/PKGBUILD b/PKGBUILD
index 7e76235a46de..5fe64413e180 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=eww
pkgname="$_pkgname-wayland-git"
-pkgver=0.4.0.r20.g8ff4142
+pkgver=0.4.0.r21.g45154bb
pkgrel=1
pkgdesc="ElKowar's wacky widgets (Wayland build)"
arch=('x86_64')
@@ -14,13 +14,21 @@ makedepends=(git rustup)
provides=("$_pkgname=${pkgver/.r*/}")
conflicts=("eww")
install=$pkgname.install
-source=("git+$url.git?signed")
-b2sums=('SKIP')
+source=("git+$url.git?signed"
+ 0001-remove-box_syntax.patch)
+b2sums=('SKIP'
+ '2953945ff2286fef89c5a08e834221b15900ef43c5422871e247ff5b6c13983f5c7a3869ae9dcc670809b10f921c6d4b822c77d07033bf36d7bf1d285589de20')
validpgpkeys=(
'B558974128820CB473BD9807E321AD71B1D1F27F' # Leon Kowarschick <5300871+elkowar@users.noreply.github.com>
'5DE3E0509C47EA3CF04A42D34AEE18F83AFDEB23' # GitHub (web-flow commit signing) <noreply@github.com>
)
+prepare() {
+ cd $_pkgname
+ # pending merge of #711
+ patch -Np1 -i ../0001-remove-box_syntax.patch
+}
+
pkgver() {
cd $_pkgname
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'