summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD27
2 files changed, 20 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb05b71edfa9..92afc72fe3a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = exaile
pkgdesc = A full-featured Amarok-style media player for GTK+
- pkgver = 3.4.4
+ pkgver = 3.4.5
pkgrel = 1
url = http://www.exaile.org
install = exaile.install
arch = any
- license = GPL
+ license = GPL2
makedepends = make
makedepends = help2man
depends = python2
@@ -16,6 +16,7 @@ pkgbase = exaile
depends = python2-dbus
depends = pygtk>=2.10
depends = librsvg
+ depends = desktop-file-utils
optdepends = pycddb: CD metadata retrieval
optdepends = python2-bsddb: music collection support
optdepends = gstreamer0.10-bad-plugins: support for more formats
@@ -29,8 +30,9 @@ pkgbase = exaile
optdepends = python2-pillow: Python Imaging Library (PIL) fork. Python2 version
optdepends = streamripper: streamripper plugin
optdepends = moodbar: moodbar plugin
- source = https://github.com/exaile-dev/exaile/archive/3.4.4.tar.gz
- sha512sums = 414f3b2844882d0ab483fabf556b4281ac44ab2328c4adf4202384bc1aaa1a0d230aebdf026982d4edd9a0aff42cd0d317785051b5d740734b670d1fe84aff13
+ optdepends = python2-mmkeys: XKeys plugin
+ source = https://github.com/exaile-dev/exaile/archive/3.4.5.tar.gz
+ sha512sums = 9337b86ed2f6a13071615bd46a7a05a6564011a4e1fef4cb42925336864c07854cfe497d8defe65c4e287fd9546de6a51543180c5ce6a84525506e57209914be
pkgname = exaile
diff --git a/PKGBUILD b/PKGBUILD
index 0d552a04c536..403a67a62335 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,12 +7,12 @@
# Contributor: Joshua Stiefer <facedelajunk@gmail.com>
pkgname=exaile
-pkgver=3.4.4
+pkgver=3.4.5
pkgrel=1
pkgdesc="A full-featured Amarok-style media player for GTK+"
arch=('any')
url="http://www.exaile.org"
-license=('GPL')
+license=('GPL2')
depends=('python2'
'gstreamer0.10-python'
'gstreamer0.10-good-plugins'
@@ -20,7 +20,8 @@ depends=('python2'
'mutagen'
'python2-dbus'
'pygtk>=2.10'
- 'librsvg')
+ 'librsvg'
+ 'desktop-file-utils')
makedepends=('make' 'help2man')
optdepends=('pycddb: CD metadata retrieval'
'python2-bsddb: music collection support'
@@ -34,22 +35,22 @@ optdepends=('pycddb: CD metadata retrieval'
'pywebkitgtk: contextinfo plugin'
'python2-pillow: Python Imaging Library (PIL) fork. Python2 version'
'streamripper: streamripper plugin'
- 'moodbar: moodbar plugin')
-source=(https://github.com/exaile-dev/exaile/archive/$pkgver.tar.gz)
+ 'moodbar: moodbar plugin'
+ 'python2-mmkeys: XKeys plugin')
+source=("https://github.com/exaile-dev/exaile/archive/$pkgver.tar.gz")
install=$pkgname.install
-sha512sums=('414f3b2844882d0ab483fabf556b4281ac44ab2328c4adf4202384bc1aaa1a0d230aebdf026982d4edd9a0aff42cd0d317785051b5d740734b670d1fe84aff13')
+sha512sums=('9337b86ed2f6a13071615bd46a7a05a6564011a4e1fef4cb42925336864c07854cfe497d8defe65c4e287fd9546de6a51543180c5ce6a84525506e57209914be')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- make PREFIX=/usr
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX="/usr"
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make PREFIX=/usr DESTDIR="${pkgdir}" install
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX="/usr" DESTDIR="$pkgdir" install
# fix for clicking files with spaces in names from nautilus
- sed -i "s#%u#%f#" "${pkgdir}/usr/share/applications/exaile.desktop"
- sed -i "s|Exec=$pkgdir/*|Exec=/|" "${pkgdir}/usr/share/dbus-1/services/org.exaile.Exaile.service"
+ sed -i "s#%u#%f#" "$pkgdir/usr/share/applications/exaile.desktop"
+ sed -i "s|Exec=$pkgdir/*|Exec=/|" "$pkgdir/usr/share/dbus-1/services/org.exaile.Exaile.service"
}