summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO36
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD55
-rw-r--r--exaile.install11
4 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fb05b71edfa9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = exaile
+ pkgdesc = A full-featured Amarok-style media player for GTK+
+ pkgver = 3.4.4
+ pkgrel = 1
+ url = http://www.exaile.org
+ install = exaile.install
+ arch = any
+ license = GPL
+ makedepends = make
+ makedepends = help2man
+ depends = python2
+ depends = gstreamer0.10-python
+ depends = gstreamer0.10-good-plugins
+ depends = gstreamer0.10-base-plugins
+ depends = mutagen
+ depends = python2-dbus
+ depends = pygtk>=2.10
+ depends = librsvg
+ optdepends = pycddb: CD metadata retrieval
+ optdepends = python2-bsddb: music collection support
+ optdepends = gstreamer0.10-bad-plugins: support for more formats
+ optdepends = gstreamer0.10-ugly-plugins: support for more formats
+ optdepends = gstreamer0.10-ffmpeg: support for more formats
+ optdepends = python2-beautifulsoup3: lyricwiki plugin
+ optdepends = python2-notify: notifyosd plugin
+ optdepends = notify-osd: notifyosd plugin
+ optdepends = webkitgtk2: contextinfo plugin
+ optdepends = pywebkitgtk: contextinfo plugin
+ optdepends = python2-pillow: Python Imaging Library (PIL) fork. Python2 version
+ optdepends = streamripper: streamripper plugin
+ optdepends = moodbar: moodbar plugin
+ source = https://github.com/exaile-dev/exaile/archive/3.4.4.tar.gz
+ sha512sums = 414f3b2844882d0ab483fabf556b4281ac44ab2328c4adf4202384bc1aaa1a0d230aebdf026982d4edd9a0aff42cd0d317785051b5d740734b670d1fe84aff13
+
+pkgname = exaile
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f32325e41657
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!exaile.install
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d552a04c536
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: X0rg
+# Contributor: Tom Kwok <contact@tomkwok.com>
+# Contributor: Jorge Barroso <jorge.barroso.11 at gmail dot com>
+# Contributor: Roman Kyrylych <Roman.Kyrylych@gmail.com>
+# Contributor: Benjamin Wild <benwild@gmx.de>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+# Contributor: Joshua Stiefer <facedelajunk@gmail.com>
+
+pkgname=exaile
+pkgver=3.4.4
+pkgrel=1
+pkgdesc="A full-featured Amarok-style media player for GTK+"
+arch=('any')
+url="http://www.exaile.org"
+license=('GPL')
+depends=('python2'
+ 'gstreamer0.10-python'
+ 'gstreamer0.10-good-plugins'
+ 'gstreamer0.10-base-plugins'
+ 'mutagen'
+ 'python2-dbus'
+ 'pygtk>=2.10'
+ 'librsvg')
+makedepends=('make' 'help2man')
+optdepends=('pycddb: CD metadata retrieval'
+ 'python2-bsddb: music collection support'
+ 'gstreamer0.10-bad-plugins: support for more formats'
+ 'gstreamer0.10-ugly-plugins: support for more formats'
+ 'gstreamer0.10-ffmpeg: support for more formats'
+ 'python2-beautifulsoup3: lyricwiki plugin'
+ 'python2-notify: notifyosd plugin'
+ 'notify-osd: notifyosd plugin'
+ 'webkitgtk2: contextinfo plugin'
+ 'pywebkitgtk: contextinfo plugin'
+ 'python2-pillow: Python Imaging Library (PIL) fork. Python2 version'
+ 'streamripper: streamripper plugin'
+ 'moodbar: moodbar plugin')
+source=(https://github.com/exaile-dev/exaile/archive/$pkgver.tar.gz)
+install=$pkgname.install
+sha512sums=('414f3b2844882d0ab483fabf556b4281ac44ab2328c4adf4202384bc1aaa1a0d230aebdf026982d4edd9a0aff42cd0d317785051b5d740734b670d1fe84aff13')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make PREFIX=/usr
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+
+ # fix for clicking files with spaces in names from nautilus
+ sed -i "s#%u#%f#" "${pkgdir}/usr/share/applications/exaile.desktop"
+ sed -i "s|Exec=$pkgdir/*|Exec=/|" "${pkgdir}/usr/share/dbus-1/services/org.exaile.Exaile.service"
+}
diff --git a/exaile.install b/exaile.install
new file mode 100644
index 000000000000..e111ef946053
--- /dev/null
+++ b/exaile.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}