summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4791104f68bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = exfat-utils-debug-git
+ pkgdesc = Utilities for the exFAT file system with debugging enabled
+ pkgver = v1.3.0.r28.gab19b44
+ pkgrel = 1
+ url = https://github.com/relan/exfat
+ arch = i686
+ arch = x86_64
+ arch = mips64el
+ arch = armv6h
+ arch = armv7h
+ arch = arm
+ arch = aarch64
+ license = GPL2
+ depends = glibc
+ provides = exfat-utils
+ conflicts = fuse-exfat
+ conflicts = exfat-utils
+ source = exfat::git+https://github.com/relan/exfat#branch=master
+ b2sums = SKIP
+
+pkgname = exfat-utils-debug-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81989f83931b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: xeruf <27f at pm dot me>
+
+pkgbasename=exfat
+pkgname=${pkgbasename}-utils-debug-git
+pkgver=v1.3.0.r28.gab19b44
+pkgrel=1
+pkgdesc='Utilities for the exFAT file system with debugging enabled'
+arch=('i686' 'x86_64' 'mips64el' 'armv6h' 'armv7h' 'arm' 'aarch64')
+url='https://github.com/relan/exfat'
+license=('GPL2')
+depends=('glibc')
+provides=('exfat-utils')
+conflicts=('fuse-exfat' 'exfat-utils')
+source=("exfat::git+https://github.com/relan/exfat#branch=master")
+b2sums=('SKIP')
+
+prepare() {
+ cd ${pkgbasename}
+ sed -i '/#define exfat_debug/D' fsck/main.c fuse/main.c
+ autoreconf -fiv
+}
+
+build() {
+ cd ${pkgbasename}
+ ./configure --prefix=/usr --sbindir=/usr/bin
+ make CCFLAGS="${CFLAGS} ${CPPFLAGS} -std=c99" LINKFLAGS="${LDFLAGS}"
+}
+
+package() {
+ cd ${pkgbasename}
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 */*.8 -t "${pkgdir}"/usr/share/man/man8
+}
+
+pkgver() {
+ cd ${pkgbasename}
+ git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}