summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--nofuse.patch31
3 files changed, 23 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7cd26634549a..e9444a8d5cd8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = exfat-utils-nofuse
pkgdesc = Utilities for the exFAT file system without fuse (to prefer exfat kernel module over fuse)
pkgver = 1.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/relan/exfat
arch = i686
arch = x86_64
@@ -18,6 +18,6 @@ pkgbase = exfat-utils-nofuse
source = exfat-1.4.0.tar.gz::https://github.com/relan/exfat/archive/v1.4.0.tar.gz
source = nofuse.patch
b2sums = a402a5cb1cc6357c7d8bdc3c0f52cd76ee5f0d01ae8f3c1ecbb3f1cfd149b1eb80099e021c27c4e6f1c306901e79b0e7543186f359db07ccd0f85f847ad6cd34
- b2sums = 6dbd6243fa3e790cd40435b1e1d149071f5b2afb7c75bdb36e96b1b6ccdd1186c3b80a4d962e899d9a402c6b9a5e9f8f26e9534a45c1df06fdf04dda858bc625
+ b2sums = 60d6cbd6fef8f9e117b44aa2416131b788378b04a9ab8f88ff23836779df92b460daab01bae646155bc58ac9f8b7071bb06717dfd7e3a06705587792e492000b
pkgname = exfat-utils-nofuse
diff --git a/PKGBUILD b/PKGBUILD
index 7b3b42e5c77d..28e1f8915d07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=exfat-utils-nofuse
pkgver=1.4.0
-pkgrel=1
+pkgrel=2
pkgdesc='Utilities for the exFAT file system without fuse (to prefer exfat kernel module over fuse)'
arch=('i686' 'x86_64' 'mips64el' 'armv6h' 'armv7h' 'arm' 'aarch64')
url='https://github.com/relan/exfat'
@@ -14,12 +14,12 @@ conflicts=('fuse-exfat' 'exfat-utils')
source=("exfat-${pkgver}.tar.gz::https://github.com/relan/exfat/archive/v${pkgver}.tar.gz"
nofuse.patch)
b2sums=('a402a5cb1cc6357c7d8bdc3c0f52cd76ee5f0d01ae8f3c1ecbb3f1cfd149b1eb80099e021c27c4e6f1c306901e79b0e7543186f359db07ccd0f85f847ad6cd34'
- '6dbd6243fa3e790cd40435b1e1d149071f5b2afb7c75bdb36e96b1b6ccdd1186c3b80a4d962e899d9a402c6b9a5e9f8f26e9534a45c1df06fdf04dda858bc625')
+ '60d6cbd6fef8f9e117b44aa2416131b788378b04a9ab8f88ff23836779df92b460daab01bae646155bc58ac9f8b7071bb06717dfd7e3a06705587792e492000b')
prepare() {
cd exfat-${pkgver}
# build without fuse support
- patch -p0 < "${srcdir}"/nofuse.patch
+ patch -p1 < "${srcdir}"/nofuse.patch
autoreconf -fiv
}
diff --git a/nofuse.patch b/nofuse.patch
index f8dd8430eb09..ceefe22007d1 100644
--- a/nofuse.patch
+++ b/nofuse.patch
@@ -1,26 +1,31 @@
-diff --git configure.ac configure.ac
---- configure.ac 2018-09-15 07:03:24.000000000 +0200
-+++ configure.ac 2019-10-28 18:02:19.792588993 +0100
-@@ -37,13 +37,11 @@
+diff -aur aaa/configure.ac bbb/configure.ac
+--- aaa/configure.ac 2023-03-02 20:49:24.000000000 +0100
++++ bbb/configure.ac 2023-03-04 23:18:54.451925996 +0100
+@@ -37,10 +37,6 @@
AC_DEFINE([USE_UBLIO], [1],
[Define if block devices are not supported.])
], [:])
--PKG_CHECK_MODULES([FUSE], [fuse])
- AC_CONFIG_HEADERS([libexfat/config.h])
- AC_CONFIG_FILES([
- libexfat/Makefile
+-PKG_CHECK_MODULES([FUSE3], [fuse3],
+- [AC_DEFINE([FUSE_USE_VERSION], [30], [Required FUSE API version.])],
+- [PKG_CHECK_MODULES([FUSE2], [fuse >= 2.6],
+- [AC_DEFINE([FUSE_USE_VERSION], [26], [Required FUSE API version.])])])
+ case "$host_os" in
+ *-gnu)
+ AC_DEFINE([_XOPEN_SOURCE], [500], [Enable pread() and pwrite().])
+@@ -53,7 +49,6 @@
+ attrib/Makefile
dump/Makefile
fsck/Makefile
- fuse/Makefile
label/Makefile
mkfs/Makefile
Makefile])
-diff --git Makefile.am Makefile.am
---- Makefile.am 2018-09-15 07:03:24.000000000 +0200
-+++ Makefile.am 2019-10-28 18:02:19.785922319 +0100
+diff -aur aaa/Makefile.am bbb/Makefile.am
+--- aaa/Makefile.am 2023-03-02 20:49:24.000000000 +0100
++++ bbb/Makefile.am 2023-03-04 23:19:01.525234081 +0100
@@ -20,4 +20,4 @@
# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
#
--SUBDIRS = libexfat dump fsck fuse label mkfs
-+SUBDIRS = libexfat dump fsck label mkfs
+-SUBDIRS = libexfat attrib dump fsck fuse label mkfs
++SUBDIRS = libexfat attrib dump fsck label mkfs