summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 19 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c82ee5c81079..c65bb347af4a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = exo-git
pkgdesc = Extensions to Xfce originally developed by os-cillation.
- pkgver = 0.12.0.r2131.03df63a
- pkgrel = 2
+ pkgver = 0.12.11+68+ga978d108
+ pkgrel = 1
epoch = 1
- url = https://git.xfce.org/xfce/exo/tree/README
+ url = https://gitlab.xfce.org/xfce/exo/
arch = i686
arch = x86_64
groups = xfce4-git
@@ -14,20 +14,14 @@ pkgbase = exo-git
makedepends = pkgconfig
makedepends = libnotify
makedepends = perl-uri
- makedepends = pygtk>=2.13
- depends = libxfce4util>=4.12
- depends = gtk3>=3.22
- depends = glib2>=2.42
- depends = gtk2>=2.24
depends = hicolor-icon-theme
- depends = libxfce4ui>=4.12
- depends = libsm
+ depends = libxfce4ui
optdepends = libnotify: enables notification support
optdepends = perl: enables mail-compose helper script
- provides = exo=0.12.0.r2131.03df63a
+ provides = exo=0.12.11+68+ga978d108
conflicts = exo
options = !libtool
- source = exo-git::git://git.xfce.org/xfce/exo
+ source = exo::git+https://gitlab.xfce.org/xfce/exo.git
md5sums = SKIP
pkgname = exo-git
diff --git a/PKGBUILD b/PKGBUILD
index c42f3292f87f..bc0b0e034e59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,42 +6,35 @@
# Contributor: Jan Jezek <honzin.jezek@gmail.com>
# Contributor: Berseker <berseker86 at gmail dot com>
-pkgname=exo-git
-pkgver=0.12.0.r2131.03df63a
-pkgrel=2
+_pkgname=exo
+pkgname=${_pkgname}-git
+pkgver=0.12.11+68+ga978d108
+pkgrel=1
pkgdesc="Extensions to Xfce originally developed by os-cillation."
arch=('i686' 'x86_64')
license=('GPL2' 'LGPL2.1')
-url="https://git.xfce.org/xfce/exo/tree/README"
+url="https://gitlab.xfce.org/xfce/exo/"
groups=('xfce4-git')
provides=("exo=${pkgver}")
-depends=('libxfce4util>=4.12' 'gtk3>=3.22' 'glib2>=2.42' 'gtk2>=2.24' 'hicolor-icon-theme' 'libxfce4ui>=4.12' 'libsm')
-makedepends=('xfce4-dev-tools' 'git' 'pkgconfig' 'libnotify' 'perl-uri' 'pygtk>=2.13')
+depends=('hicolor-icon-theme' 'libxfce4ui')
+makedepends=('xfce4-dev-tools' 'git' 'pkgconfig' 'libnotify' 'perl-uri')
optdepends=('libnotify: enables notification support'
'perl: enables mail-compose helper script')
conflicts=('exo')
-source=('exo-git::git://git.xfce.org/xfce/exo')
+source=("${_pkgname}::git+https://gitlab.xfce.org/xfce/${_pkgname}.git")
options=('!libtool')
md5sums=('SKIP')
epoch=1
pkgver(){
- cd exo-git
- _majorversion=$(grep -F "m4_define([libexo_version_major]" configure.ac.in | awk 'BEGIN {FS = "["} {print $3}' | sed -r 's/(\[|\])//g' | sed -r 's/(\(|\))//g')
- _minorversion=$(grep -F "m4_define([libexo_version_minor]" configure.ac.in | awk 'BEGIN {FS = "["} {print $3}' | sed -r 's/(\[|\])//g' | sed -r 's/(\(|\))//g')
- _microversion=$(grep -F "m4_define([libexo_version_micro]" configure.ac.in | awk 'BEGIN {FS = "["} {print $3}' | sed -r 's/(\[|\])//g' | sed -r 's/(\(|\))//g')
+ cd "${_pkgname}"
+ git describe --long --tags | sed -r "s:^${_pkgname}.::;s/^v//;s/^exo-//;s/-/+/g"
+# git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
- printf "%s." "$_majorversion"
- printf "%s." "$_minorversion"
- printf "%s." "$_microversion"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd $srcdir/exo-git
-
- # Python 2 fix
- export PYTHON=python2
+ cd "${_pkgname}"
./autogen.sh \
--prefix=/usr \
@@ -50,13 +43,11 @@ build() {
--localstatedir=/var \
--disable-static \
--enable-gtk-doc \
- --enable-gtk2 \
- --enable-gtk3 \
--disable-debug
make
}
package() {
- cd $srcdir/exo-git
+ cd "${_pkgname}"
make DESTDIR=$pkgdir install
}