summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f7bf47b48ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = extract-xiso
+ pkgdesc = xdvdfs (xbox iso) file creation and extraction utility
+ pkgver = 2.7.1
+ pkgrel = 1
+ url = http://sourceforge.net/projects/extract-xiso
+ arch = i686
+ arch = x86_64
+ license = custom
+ conflicts = extract-xiso-somski
+ source = http://downloads.sourceforge.net/extract-xiso/extract-xiso-2.7.1.tar.gz
+ md5sums = 464aeb312aca6f4a1ffee42384b3c738
+
+pkgname = extract-xiso
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0276f7a43dbf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Joe Carta <cartakid at gmail dot com>
+# Contributor: sidious/SiD <miste78 web de>
+# Contributor: Wes Brewer <brewerw@gmail.com>
+
+pkgname=extract-xiso
+pkgver=2.7.1
+pkgrel=1
+pkgdesc="xdvdfs (xbox iso) file creation and extraction utility"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/extract-xiso"
+license=('custom')
+conflicts=('extract-xiso-somski')
+source=(http://downloads.sourceforge.net/$pkgname/${pkgname}-${pkgver}.tar.gz)
+md5sums=('464aeb312aca6f4a1ffee42384b3c738')
+
+build() {
+ cd ${srcdir}/${pkgname}
+ # build
+ make
+}
+package() {
+ cd ${srcdir}/${pkgname}
+ # install binary
+ install -Dm755 extract-xiso ${pkgdir}/usr/bin/extract-xiso
+ # install custom license
+ install -Dm644 LICENSE.TXT ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.TXT
+}