summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-x.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2687f64d3df..48175712a97c 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ez
pkgdesc = Task simplificaltion scripts that increase speed and efficiency in common tasks
- pkgver = 1.1.2
+ pkgver = 1.1.3
pkgrel = 1
url = https://gitlab.com/a4to/ez
arch = any
@@ -10,12 +10,13 @@ pkgbase = ez
optdepends = snapd: To install snap packages with ezdl
optdepends = python-pip: To install python packages with ezdl
optdepends = lf: To integrate the lf file manager with eztst
+ optdepends = bluez: To integrate EZ bluetooth manager
provides = ez
provides = ezdl
provides = ezgc
provides = eztst
provides = ezssl
- source = https://gitlab.com/a4to/concise/-/raw/master/x86_64/ez-1.1.2-1-any.pkg.tar.zst
- sha256sums = 979c0229b19c4b0f614a2f0f3defca1317ac79904265672d8bfb5e57b9944ae8
+ source = https://gitlab.com/a4to/concise/-/raw/master/x86_64/ez-1.1.3-1-any.pkg.tar.zst
+ sha256sums = 83da51cce10f358461569023bb29364f8871185697385f9161fb4c1b025e3999
pkgname = ez
diff --git a/PKGBUILD b/PKGBUILD
index 6dd23882b713..695f2523f0a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Connor Etherington <connor@concise.cc>
# ---
pkgname=ez
-pkgver=1.1.2
+pkgver=1.1.3
pkgrel=1
pkgdesc='Task simplificaltion scripts that increase speed and efficiency in common tasks'
arch=('any')
@@ -14,14 +14,17 @@ optdepends=(
"snapd: To install snap packages with ezdl"
"python-pip: To install python packages with ezdl"
"lf: To integrate the lf file manager with eztst"
+ "bluez: To integrate EZ bluetooth manager"
)
provides=(ez ezdl ezgc eztst ezssl)
source=("https://gitlab.com/a4to/concise/-/raw/master/x86_64/${pkgname}-${pkgver}-${pkgrel}-$arch.pkg.tar.zst")
-sha256sums=('979c0229b19c4b0f614a2f0f3defca1317ac79904265672d8bfb5e57b9944ae8')
+sha256sums=('83da51cce10f358461569023bb29364f8871185697385f9161fb4c1b025e3999')
package() {
+ cd ${pkgname}
install -Dm775 usr/bin/* -t "${pkgdir}/usr/bin/"
install -Dm644 usr/share/licenses/${pkgname}/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- for x in ezdl ezgc eztst ezssl; do
+ for x in $(ls usr/doc/${pkgname}); do
install -Dm644 usr/share/doc/${pkgname}/${x}/README "${pkgdir}/usr/share/doc/${pkgname}/${x}/README"
- done ; }
+ done
+ }