summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--[-rwxr-xr-x]PKGBUILD45
2 files changed, 34 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 100cd5f25eb0..924741944541 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = faba-icon-theme-git
- pkgdesc = This is the base icon set for Faba. It is designed with simplicity and compliance to standards in mind.
- pkgver = 294.ab92a4c
- pkgrel = 2
- url = http://mokaproject.com/faba-icon-theme/
+ pkgdesc = A sexy and modern FreeDesktop icon set with Tango and elementary influences
+ pkgver = 4.3
+ pkgrel = 1
+ url = https://snwh.org/moka
install = faba-icon-theme.install
arch = any
license = GPL3
+ license = CCPL:by-sa
makedepends = git
+ makedepends = meson
depends = gtk-update-icon-cache
provides = faba-icon-theme
conflicts = faba-icon-theme
- replaces = faba-icon-theme
options = !strip
- source = faba-icon-theme::git+https://github.com/moka-project/faba-icon-theme.git
+ source = git+https://github.com/snwh/faba-icon-theme.git
sha256sums = SKIP
pkgname = faba-icon-theme-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 548e362e14b4..cdb9ee4453d2 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,40 @@
-# Maintainer: Martin Wimpress <code@flexion.org>
+# Contributor: Eric Fung <loseurmarbles[AT]gmail[DOT]com>
+# Contributor: Martin Wimpress <code@flexion.org>
-_pkgname=faba-icon-theme
-pkgname=${_pkgname}-git
-pkgver=294.ab92a4c
-pkgrel=2
-pkgdesc="This is the base icon set for Faba. It is designed with simplicity and compliance to standards in mind."
+pkgname=faba-icon-theme-git
+_pkgname=${pkgname%-git}
+pkgver=4.3
+pkgrel=1
+pkgdesc='A sexy and modern FreeDesktop icon set with Tango and elementary influences'
arch=('any')
-url="http://mokaproject.com/faba-icon-theme/"
-license=('GPL3')
+url='https://snwh.org/moka'
+license=('GPL3' 'CCPL:by-sa')
depends=('gtk-update-icon-cache')
-makedepends=('git')
+makedepends=('git' 'meson')
conflicts=("${_pkgname}")
provides=("${_pkgname}")
-replaces=("${_pkgname}")
-options=(!strip)
-source=(${_pkgname}::"git+https://github.com/moka-project/${_pkgname}.git")
+options=('!strip')
+source=("git+https://github.com/snwh/${_pkgname}.git")
sha256sums=('SKIP')
install=${_pkgname}.install
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ # Remove execute permission on files
+ chmod -R -x+X .
+}
+
pkgver() {
- cd ${srcdir}/${_pkgname}
- echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ meson --prefix=/usr --buildtype=plain "build"
}
package() {
- install -d -m 755 "${pkgdir}"/usr/share/icons/Faba
- cp -dr --no-preserve=ownership "${_pkgname}"/Faba "${pkgdir}"/usr/share/icons/
- find "${pkgdir}"/usr/share/icons/ -type d -exec chmod 755 {} \;
- find "${pkgdir}"/usr/share/icons/ -type f -exec chmod 644 {} \;
+ cd "${srcdir}/${_pkgname}"
+ DESTDIR="${pkgdir}" ninja -C "build" install
}