summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rwxr-xr-xPKGBUILD31
-rw-r--r--faba-icon-theme.install11
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..100cd5f25eb0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = faba-icon-theme-git
+ pkgdesc = This is the base icon set for Faba. It is designed with simplicity and compliance to standards in mind.
+ pkgver = 294.ab92a4c
+ pkgrel = 2
+ url = http://mokaproject.com/faba-icon-theme/
+ install = faba-icon-theme.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gtk-update-icon-cache
+ provides = faba-icon-theme
+ conflicts = faba-icon-theme
+ replaces = faba-icon-theme
+ options = !strip
+ source = faba-icon-theme::git+https://github.com/moka-project/faba-icon-theme.git
+ sha256sums = SKIP
+
+pkgname = faba-icon-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..548e362e14b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Martin Wimpress <code@flexion.org>
+
+_pkgname=faba-icon-theme
+pkgname=${_pkgname}-git
+pkgver=294.ab92a4c
+pkgrel=2
+pkgdesc="This is the base icon set for Faba. It is designed with simplicity and compliance to standards in mind."
+arch=('any')
+url="http://mokaproject.com/faba-icon-theme/"
+license=('GPL3')
+depends=('gtk-update-icon-cache')
+makedepends=('git')
+conflicts=("${_pkgname}")
+provides=("${_pkgname}")
+replaces=("${_pkgname}")
+options=(!strip)
+source=(${_pkgname}::"git+https://github.com/moka-project/${_pkgname}.git")
+sha256sums=('SKIP')
+install=${_pkgname}.install
+
+pkgver() {
+ cd ${srcdir}/${_pkgname}
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+package() {
+ install -d -m 755 "${pkgdir}"/usr/share/icons/Faba
+ cp -dr --no-preserve=ownership "${_pkgname}"/Faba "${pkgdir}"/usr/share/icons/
+ find "${pkgdir}"/usr/share/icons/ -type d -exec chmod 755 {} \;
+ find "${pkgdir}"/usr/share/icons/ -type f -exec chmod 644 {} \;
+}
diff --git a/faba-icon-theme.install b/faba-icon-theme.install
new file mode 100644
index 000000000000..504c9c41aa4f
--- /dev/null
+++ b/faba-icon-theme.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f /usr/share/icons/Faba
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}