aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD55
-rw-r--r--README.md16
3 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..115e526e0284
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = fakexrandr-git
+ pkgdesc = Fake XRandR configurations for multi-head setups with crappy video drivers, like fakexinerama but with xrandr
+ pkgver = 0.0.0
+ pkgrel = 1
+ url = https://github.com/pschmitt/fakexrandr
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = glibc
+ makedepends = sed
+ depends = xorg-xrandr
+ source = fakexrandr-git::git://github.com/pschmitt/fakexrandr.git
+ sha1sums = SKIP
+
+pkgname = fakexrandr-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..76e913762731
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Philipp Schmitt <philipp@schmitt.co>
+# Upstream: https://github.com/phillipberndt/fakexrandr
+pkgname=fakexrandr-git
+pkgver=0.0.0
+pkgrel=1
+pkgdesc="Fake XRandR configurations for multi-head setups with crappy video drivers, like fakexinerama but with xrandr"
+arch=(any)
+url="https://github.com/pschmitt/fakexrandr"
+license=('GPL')
+depends=('xorg-xrandr')
+makedepends=('git' 'glibc' 'sed')
+source=("$pkgname"::'git://github.com/pschmitt/fakexrandr.git')
+sha1sums=('SKIP')
+
+_pkgname=fakexrandr
+_lib_dir=/usr/lib/$_pkgname
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ # Use the tag of the last commit
+ git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ # Fix python interpreter (python -> python2)
+ sed -i '1s/python/python2/g' make_skeleton.py
+ # Add custom fakexrandr lib path (bypass detection)
+ sed -i "s|^\(FAKE_LIBRARY_DIRECTORY=\)$|\1${_lib_dir}|" configure
+ # FIXME THIS AINT WORKING
+ # Fix missing target
+ sed -i "s|\(install}\) \(.*\) \(.*\);|\1 \2 \3\2;|" Makefile
+ # Fix missing DEST_DIR in Makefile
+ sed -i "s|\(TARGET_DIR=\).*|\1${pkgdir}${_lib_dir}|" Makefile
+ # Don't even try to run ldconfig now
+ sed -i "s/\(ldconfig\)/#\1/" Makefile
+ # Create ld.so.conf.d config file
+ echo "$_lib_dir" > "${_pkgname}.conf"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ ./configure
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ echo cd "$srcdir/$pkgname"
+ mkdir -p "$pkgdir/$_lib_dir"
+ make install
+ install -D -m 644 "${_pkgname}.conf" "$pkgdir/etc/ld.so.conf.d/${_pkgname}.conf"
+}
+
+# vim: set et ts=2 sw=2 :
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..b4afe53010c0
--- /dev/null
+++ b/README.md
@@ -0,0 +1,16 @@
+# fakexrandr
+
+## Description
+
+AUR package for fakexrandr
+
+## Installation
+
+```bash
+wget https://raw.github.com/pschmitt/aur-fakexrandr/PKGBUILD
+makepkg -si
+```
+
+## Links
+* Upstream: https://github.com/phillipberndt/fakexrandr
+* AUR: https://aur.archlinux.org/packages/fakexrandr