aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 115e526e0284..3fb57075dfda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,14 +2,15 @@ pkgbase = fakexrandr-git
pkgdesc = Fake XRandR configurations for multi-head setups with crappy video drivers, like fakexinerama but with xrandr
pkgver = 0.0.0
pkgrel = 1
- url = https://github.com/pschmitt/fakexrandr
+ url = https://github.com/phillippberndt/fakexrandr
arch = any
license = GPL
makedepends = git
makedepends = glibc
makedepends = sed
+ makedepends = python2
depends = xorg-xrandr
- source = fakexrandr-git::git://github.com/pschmitt/fakexrandr.git
+ source = fakexrandr-git::git://github.com/phillipberndt/fakexrandr.git
sha1sums = SKIP
pkgname = fakexrandr-git
diff --git a/PKGBUILD b/PKGBUILD
index 76e913762731..dd7b63f56c50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,11 +5,11 @@ pkgver=0.0.0
pkgrel=1
pkgdesc="Fake XRandR configurations for multi-head setups with crappy video drivers, like fakexinerama but with xrandr"
arch=(any)
-url="https://github.com/pschmitt/fakexrandr"
+url="https://github.com/phillippberndt/fakexrandr"
license=('GPL')
depends=('xorg-xrandr')
-makedepends=('git' 'glibc' 'sed')
-source=("$pkgname"::'git://github.com/pschmitt/fakexrandr.git')
+makedepends=('git' 'glibc' 'sed' 'python2')
+source=("$pkgname"::'git://github.com/phillipberndt/fakexrandr.git')
sha1sums=('SKIP')
_pkgname=fakexrandr
@@ -29,9 +29,9 @@ prepare() {
sed -i "s|^\(FAKE_LIBRARY_DIRECTORY=\)$|\1${_lib_dir}|" configure
# FIXME THIS AINT WORKING
# Fix missing target
- sed -i "s|\(install}\) \(.*\) \(.*\);|\1 \2 \3\2;|" Makefile
+ sed -i "s|\(install\) \(.*\) \(.*\);|\1 \2 \3/\2;|" Makefile
# Fix missing DEST_DIR in Makefile
- sed -i "s|\(TARGET_DIR=\).*|\1${pkgdir}${_lib_dir}|" Makefile
+ sed -i "s|\(TARGET_DIR=\).*|\1${pkgdir}${_lib_dir}; \\\|" Makefile
# Don't even try to run ldconfig now
sed -i "s/\(ldconfig\)/#\1/" Makefile
# Create ld.so.conf.d config file