summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD48
2 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0307f95217f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+# Generated by mksrcinfo v8
+# Wed Sep 6 03:25:54 UTC 2017
+pkgbase = falkon-git
+ pkgdesc = Cross-platform Qt Web Browser
+ pkgver = 2.1.2.r4422.d42b1ecf
+ pkgrel = 1
+ url = http://www.qupzilla.com
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = qt5-tools
+ makedepends = kwallet
+ makedepends = libgnome-keyring
+ depends = qt5-webengine
+ depends = qt5-x11extras
+ depends = qt5-svg
+ depends = hicolor-icon-theme
+ depends = openssl>=1.1.0
+ optdepends = bash-completion: bash completion support
+ optdepends = kwallet: kf5 kwallet integration
+ optdepends = libgnome-keyring: gnome keyring integration
+ conflicts = qupzilla
+ conflicts = qupzilla-qt5
+ conflicts = qupzilla-qt5-git
+ conflicts = falkon
+ source = git://anongit.kde.org/falkon.git
+ sha256sums = SKIP
+
+pkgname = falkon-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff6b8ebd9be2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Mantainer: epitron <chris@ill-logic.com>
+# Contributor: sxe <sxxe@gmx.de>
+
+pkgname=falkon-git
+_pkgname=falkon
+pkgver=2.1.2.r4422.d42b1ecf
+_pkgver=2.1.2
+pkgrel=1
+pkgdesc="Cross-platform Qt Web Browser "
+arch=('i686' 'x86_64')
+url="http://www.qupzilla.com"
+license=('GPL')
+depends=('qt5-webengine' 'qt5-x11extras' 'qt5-svg' 'hicolor-icon-theme' 'openssl>=1.1.0')
+makedepends=('git' 'qt5-tools' 'kwallet' 'libgnome-keyring')
+conflicts=('qupzilla' 'qupzilla-qt5' 'qupzilla-qt5-git' 'falkon')
+optdepends=(
+ 'bash-completion: bash completion support'
+ 'kwallet: kf5 kwallet integration'
+ 'libgnome-keyring: gnome keyring integration'
+ )
+source=(
+ "git://anongit.kde.org/falkon.git"
+ )
+sha256sums=(SKIP)
+
+pkgver() {
+ cd "$_pkgname"
+ printf "$_pkgver.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+
+ export FALKON_PREFIX="/usr/"
+ export KDE_INTEGRATION=true
+ export GNOME_INTEGRATION=true
+
+ qmake
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ make INSTALL_ROOT="$pkgdir/" install
+
+ # zsh completion
+ install -Dm644 linux/completion/_falkon "$pkgdir/usr/share/zsh/site-functions/_falkon"
+}