summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c4f76cd1d463..cc338256fa35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fanicontrol
pkgdesc = a new way controling your fans
- pkgver = 0.28
+ pkgver = 0.30
pkgrel = 1
url = https://github.com/tsonntig/Fanicontrol
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 1437de4d3ad6..dfe5d2ac3e7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
# Maintainer: tsonntig
pkgname=fanicontrol
-pkgver=0.28
+pkgver=0.30
pkgrel=1
pkgdesc="a new way controling your fans"
arch=('any')
url="https://github.com/tsonntig/Fanicontrol"
license=('GPL2 only')
depends=(python3)
-makedepends=('git' 'python-setuptools')
+makedepends=('git')
source=('git+https://github.com/tsonntig/Fanicontrol.git')
md5sums=('SKIP')
package() {
cd "$srcdir/Fanicontrol"
- install -Dm644 'arch/fanicontrol.service' "$pkgdir/usr/lib/systemd/system/fanicontrol.service"
python arch/setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 'doc/fanic.gz' "$pkgdir/usr/share/man/man5/fanicontrol.conf.5.gz"
+ install -Dm644 'arch/fanicontrol.service' "$pkgdir/usr/lib/systemd/system/fanicontrol.service"
}