summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d5a868f3175d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = fann-git
+ pkgdesc = Fast artificial neural network library
+ pkgver = 2.2.0.r57.g0e6fa25
+ pkgrel = 1
+ url = http://leenissen.dk/fann/
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = cmake
+ provides = fann
+ conflicts = fann
+ source = fann-git::git+https://github.com/libfann/fann.git
+ md5sums = SKIP
+
+pkgname = fann-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..97c08cc7c05a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: Andreas Hauser <andy-aur@splashground.de>
+# Contributor: Beej Jorgensen <beej@beej.us>
+# Maintainer: Thomas Laroche <tho.laroche@gmail.com>
+pkgname=fann-git
+pkgver=2.2.0.r57.g0e6fa25
+pkgrel=1
+pkgdesc="Fast artificial neural network library"
+url="http://leenissen.dk/fann/"
+arch=('i686' 'x86_64')
+license=('LGPL2.1')
+makedepends=('cmake')
+source=("$pkgname::git+https://github.com/libfann/fann.git")
+md5sums=('SKIP')
+conflicts=('fann')
+provides=('fann')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $srcdir/$pkgname
+ cmake -D CMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname
+ make DESTDIR=$pkgdir install
+}