summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 449497dc9d3f..c97765dfc825 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = far2l-git
pkgdesc = Linux port of FAR v2
- pkgver = r3780.26da207d
+ pkgver = r3846.15798797
pkgrel = 1
url = https://github.com/elfmz/far2l
arch = i686
@@ -8,11 +8,12 @@ pkgbase = far2l-git
license = GPL2
makedepends = git
makedepends = cmake
- depends = wxgtk3
- depends = openssl
depends = xerces-c
depends = fmt
depends = uchardet
+ optdepends = libxi: TTY X11 backend
+ optdepends = wxwidgets-gtk3: wxWidgets GUI backend
+ optdepends = openssl: FTPS support in NetRocks
optdepends = libssh: SFTP support in NetRocks
optdepends = smbclient: SMB support in NetRocks
optdepends = libnfs: NFS support in NetRocks
diff --git a/PKGBUILD b/PKGBUILD
index 089ae7bb1564..706fccceb01a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Martins Mozeiko <martins.mozeiko@gmail.com>
pkgname=far2l-git
-pkgver=r3780.26da207d
+pkgver=r3846.15798797
pkgrel=1
pkgdesc='Linux port of FAR v2'
url='https://github.com/elfmz/far2l'
@@ -10,8 +10,11 @@ license=('GPL2')
source=('git+https://github.com/elfmz/far2l')
sha256sums=('SKIP')
makedepends=('git' 'cmake')
-depends=('wxgtk3' 'openssl' 'xerces-c' 'fmt' 'uchardet')
+depends=('xerces-c' 'fmt' 'uchardet')
optdepends=(
+ 'libxi: TTY X11 backend'
+ 'wxwidgets-gtk3: wxWidgets GUI backend'
+ 'openssl: FTPS support in NetRocks'
'libssh: SFTP support in NetRocks'
'smbclient: SMB support in NetRocks'
'libnfs: NFS support in NetRocks'
@@ -28,9 +31,6 @@ pkgver() {
package() {
cd "$srcdir"/far2l
- cmake . -DCMAKE_INSTALL_PREFIX="$pkgdir"/usr -DCMAKE_BUILD_TYPE=Release -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config -DCMAKE_CXX_FLAGS=-w
+ cmake . -DCMAKE_INSTALL_PREFIX="${pkgdir}"/usr -DCMAKE_BUILD_TYPE=Release
cmake --build . --target install
-
- ln -sf ../../bin/far2l "$pkgdir"/usr/lib/far2l/far2l_askpass
- ln -sf ../../bin/far2l "$pkgdir"/usr/lib/far2l/far2l_sudoapp
}