summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD18
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b713c29d7d5..7af6b3ad0fa9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fast-p
pkgdesc = Quickly find and open a pdf among a collection of thousands of unsorted pdfs through fzf (fuzzy finder)
pkgver = 0.2.5
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/bellecp/fast-p
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 8d2886226d0a..75c79686e8a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=fast-p
pkgver=0.2.5
-pkgrel=2
+pkgrel=3
pkgdesc='Quickly find and open a pdf among a collection of thousands of unsorted pdfs through fzf (fuzzy finder)'
arch=('x86_64')
repo="github.com/bellecp/$pkgname"
@@ -14,16 +14,16 @@ sha256sums=('ccd0a4630433a0ed000278f93c15300fd8bf47e612967568d824ad4ab23fb3ac')
gopkg="gopath/src/$repo"
prepare() {
- mkdir -p ${gopkg%/*}
- ln -rTsf $pkgname-$pkgver $gopkg
- export GOPATH="$srcdir"/gopath
- cd $gopkg
+ mkdir -p "${gopkg%/*}"
+ ln -rTsf "$pkgname-$pkgver" "$gopkg"
+ export GOPATH="$srcdir/gopath"
+ cd "$gopkg"
go get -v -d
}
build() {
export GOPATH="$srcdir"/gopath
- cd $gopkg
+ cd "$gopkg"
go install \
-trimpath \
-ldflags "-extldflags $LDFLAGS" \
@@ -38,7 +38,7 @@ build() {
# }
package() {
- install -Dm755 gopath/bin/$pkgname "$pkgdir"/usr/bin/$pkgname
- cd $pkgname-$pkgver
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/LICENSE
+ install -Dm755 "gopath/bin/$pkgname" -t "$pkgdir/usr/bin"
+ cd "$pkgname-$pkgver"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}