summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
-rw-r--r--allow-py312.patch11
3 files changed, 24 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffe7aff61a7f..6a2e9090eab6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fastflix
pkgdesc = Simple and friendly GUI for encoding videos
- pkgver = 5.5.7
- pkgrel = 1
+ pkgver = 5.6.0
+ pkgrel = 2
url = https://github.com/cdgriffith/FastFlix
arch = x86_64
license = MIT
@@ -15,9 +15,11 @@ pkgbase = fastflix
optdepends = x264: encoding to H264/AVC
optdepends = rav1e: encoding to AV1
optdepends = libwebp: encoding to WebP
- source = git+https://github.com/cdgriffith/FastFlix.git#tag=5.5.7
+ source = git+https://github.com/cdgriffith/FastFlix.git#tag=5.6.0
+ source = allow-py312.patch
source = FastFlix.desktop
sha256sums = SKIP
+ sha256sums = e7da5b816d19c4e96f906340d82ab4dd35d36472a075370707f9ea2e0b06b36c
sha256sums = cbcb6f228b858a69a860aa6a3283f0f4293e1246485566d20f60a93030f1f847
pkgname = fastflix
diff --git a/PKGBUILD b/PKGBUILD
index e5f316b9dd33..9fe87c057649 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Norbert Preining <norbert@preining.info>
_UpstreamPkgName=FastFlix
pkgname=${_UpstreamPkgName,,}
-pkgver=5.5.7
-pkgrel=1
+pkgver=5.6.0
+pkgrel=2
pkgdesc="Simple and friendly GUI for encoding videos"
arch=('x86_64')
url="https://github.com/cdgriffith/$_UpstreamPkgName"
@@ -15,14 +15,16 @@ optdepends=('nvenc: hardware accelerated encoding on NVIDIA cards'
'rav1e: encoding to AV1'
'libwebp: encoding to WebP')
source=(git+${url}.git#tag=${pkgver}
+ allow-py312.patch
FastFlix.desktop)
sha256sums=('SKIP'
+ 'e7da5b816d19c4e96f906340d82ab4dd35d36472a075370707f9ea2e0b06b36c'
'cbcb6f228b858a69a860aa6a3283f0f4293e1246485566d20f60a93030f1f847')
-# prepare() {
-# cd $_UpstreamPkgName
-# patch --forward --strip=1 --input="${srcdir}/allow-python310.patch"
-# }
+prepare() {
+ cd $_UpstreamPkgName
+ patch --forward --strip=0 --input="${srcdir}/allow-py312.patch"
+}
build() {
cd ${_UpstreamPkgName}
diff --git a/allow-py312.patch b/allow-py312.patch
new file mode 100644
index 000000000000..1c151f6a3d6c
--- /dev/null
+++ b/allow-py312.patch
@@ -0,0 +1,11 @@
+--- pyproject.toml.orig 2024-06-03 10:17:31.803227004 +0900
++++ pyproject.toml 2024-06-03 10:17:49.846066995 +0900
+@@ -21,7 +21,7 @@
+ readme = "README.md"
+ #url = "https://fastflix.org"
+ #download_url = "https://github.com/cdgriffith/FastFlix/releases"
+-requires-python = ">=3.11,<3.12"
++requires-python = ">=3.11,<3.13"
+ dynamic = ["version"]
+ dependencies = [
+ "appdirs~=1.4",