summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d2bfc98896bf..bb2c4a2bd57d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fastgame-git
pkgdesc = Optimize system performance for games
- pkgver = 0.0.9.r53.g43786aa
+ pkgver = 0.2.0.r0.g6a53b7c
pkgrel = 1
url = https://github.com/wwmm/fastgame
arch = x86_64
@@ -10,14 +10,13 @@ pkgbase = fastgame-git
makedepends = boost
makedepends = itstool
depends = boost-libs
- depends = gtk3
- depends = gtkmm3
- depends = glibmm
- depends = libsigc++
+ depends = gtk4
+ depends = glib2
+ depends = fmt
+ depends = libsigc++-3.0
provides = fastgame
conflicts = fastgame
source = git+https://github.com/wwmm/fastgame.git
sha512sums = SKIP
pkgname = fastgame-git
-
diff --git a/PKGBUILD b/PKGBUILD
index d2890b8b61e4..1d0dec90e4ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Wellington <wellingtonwallace@gmail.com>
pkgname=fastgame-git
-pkgver=0.0.9.r53.g43786aa
+pkgver=0.2.0.r0.g6a53b7c
pkgrel=1
pkgdesc='Optimize system performance for games'
arch=(x86_64 i686)
url='https://github.com/wwmm/fastgame'
license=('GPL3')
-depends=('boost-libs' 'gtk3' 'gtkmm3' 'glibmm' 'libsigc++')
+depends=('boost-libs' 'gtk4' 'glib2' 'fmt' 'libsigc++-3.0')
makedepends=('meson' 'boost' 'itstool')
source=("git+https://github.com/wwmm/fastgame.git")
conflicts=(fastgame)
@@ -20,16 +20,11 @@ pkgver() {
}
build() {
- mkdir -p fastgame/build
- cd fastgame/build
+ arch-meson fastgame build
- arch-meson ..
-
- ninja
+ ninja -C build
}
package() {
- cd fastgame/build
-
- DESTDIR="$pkgdir" ninja install
+ DESTDIR="${pkgdir}" ninja install -C build
}