summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--CHANGELOG.md17
-rw-r--r--PKGBUILD5
3 files changed, 21 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7830c87bb6f7..114453fd1826 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fastly
pkgdesc = CLI for the Fastly platform
- pkgver = 4.1.0
+ pkgver = 4.2.0
pkgrel = 1
url = https://github.com/fastly/cli
changelog = CHANGELOG.md
@@ -11,7 +11,7 @@ pkgbase = fastly
makedepends = git
makedepends = go
depends = glibc
- source = fastly::git+https://github.com/fastly/cli#tag=v4.1.0?signed
+ source = fastly::git+https://github.com/fastly/cli#tag=v4.2.0?signed
validpgpkeys = A4C2C78656BA5E3DD5F122E4BCE379A5D550C407
validpgpkeys = 5DE3E0509C47EA3CF04A42D34AEE18F83AFDEB23
sha256sums = SKIP
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 9a843b3f5232..9b1255c4e687 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,5 +1,22 @@
# Changelog
+## [v4.2.0](https://github.com/fastly/cli/releases/tag/v4.2.0) (2022-10-18)
+
+[Full Changelog](https://github.com/fastly/cli/compare/v4.1.0...v4.2.0)
+
+**Enhancements:**
+
+* Service Authorization [#660](https://github.com/fastly/cli/pull/660)
+* Add Object Store API calls [#670](https://github.com/fastly/cli/pull/670)
+* Remove upper limit on Go toolchain [#678](https://github.com/fastly/cli/pull/678)
+
+**Bug fixes:**
+
+* Fix `compute pack` to produce expected `package.tar.gz` filename [#662](https://github.com/fastly/cli/pull/662)
+* Fix `--help` flag to not display an error [#672](https://github.com/fastly/cli/pull/672)
+* Fix command substitution issue for Windows OS [#677](https://github.com/fastly/cli/pull/677)
+* Fix Makefile for Windows [#679](https://github.com/fastly/cli/pull/679)
+
## [v4.1.0](https://github.com/fastly/cli/releases/tag/v4.1.0) (2022-10-11)
[Full Changelog](https://github.com/fastly/cli/compare/v4.0.1...v4.1.0)
diff --git a/PKGBUILD b/PKGBUILD
index b2cb9325cc93..f7a8f18224e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
## GPG key: https://github.com/web-flow.gpg
pkgname=fastly
-pkgver=4.1.0
+pkgver=4.2.0
pkgrel=1
pkgdesc='CLI for the Fastly platform'
url='https://github.com/fastly/cli'
@@ -16,8 +16,7 @@ changelog=CHANGELOG.md
source=("$pkgname::git+$url#tag=v$pkgver?signed")
sha256sums=('SKIP')
validpgpkeys=('A4C2C78656BA5E3DD5F122E4BCE379A5D550C407' ## Mark McDonnell (Integralist)
- '5DE3E0509C47EA3CF04A42D34AEE18F83AFDEB23' ## GitHub
-)
+ '5DE3E0509C47EA3CF04A42D34AEE18F83AFDEB23') ## GitHub
prepare() {
cd "$pkgname"