summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 3 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f3812da3047..8bae59a6b839 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fastp
pkgdesc = a tool designed to provide fast all-in-one preprocessing for FastQ files, developed in C++ with multithreading supported to afford high performance
pkgver = 0.23.4
- pkgrel = 1
+ pkgrel = 3
url = https://github.com/OpenGene/fastp
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 52e2b39512b5..09dbea3fca9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Baytars <feicuihuangfeng@qq.com>
pkgname=fastp
pkgver=0.23.4
-pkgrel=1
+pkgrel=3
pkgdesc="a tool designed to provide fast all-in-one preprocessing for FastQ files, developed in C++ with multithreading supported to afford high performance"
url="https://github.com/OpenGene/fastp"
license=('MIT')
@@ -22,6 +22,5 @@ build() {
}
package() {
cd "${srcdir}/${pkgname}-$pkgver"
- mkdir -p "${pkgdir}/usr/bin/${pkgname}"
- install ${pkgname} ${pkgdir}/usr/bin/${pkgname}
+ install -Dm755 ${pkgname} ${pkgdir}/usr/bin/${pkgname}
}