summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa416f1ba530
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = fasttext-langid-models
+ pkgdesc = Library for fast text representation and classification – pre-trained models for language identification
+ pkgver = 0.0.1
+ pkgrel = 0
+ url = https://fasttext.cc/docs/en/language-identification.html
+ arch = any
+ license = custom:CC-BY-SA
+ noextract = lid.176.bin
+ noextract = lid.176.ftz
+ source = https://s3-us-west-1.amazonaws.com/fasttext-vectors/supervised_models/lid.176.bin
+ source = https://s3-us-west-1.amazonaws.com/fasttext-vectors/supervised_models/lid.176.ftz
+ sha256sums = 7e69ec5451bc261cc7844e49e4792a85d7f09c06789ec800fc4a44aec362764e
+ sha256sums = 8f3472cfe8738a7b6099e8e999c3cbfae0dcd15696aac7d7738a8039db603e83
+
+pkgname = fasttext-langid-models
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cce3f1a0089b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: peippo <christoph.fink@gmail.com>
+
+pkgname="fasttext-langid-models"
+pkgdesc="Library for fast text representation and classification – pre-trained models for language identification"
+url="https://fasttext.cc/docs/en/language-identification.html"
+
+pkgver=0.0.1
+pkgrel=0
+
+arch=("any")
+license=("custom:CC-BY-SA")
+
+source=(
+ "https://s3-us-west-1.amazonaws.com/fasttext-vectors/supervised_models/lid.176.bin"
+ "https://s3-us-west-1.amazonaws.com/fasttext-vectors/supervised_models/lid.176.ftz"
+)
+sha256sums=(
+ "7e69ec5451bc261cc7844e49e4792a85d7f09c06789ec800fc4a44aec362764e"
+ "8f3472cfe8738a7b6099e8e999c3cbfae0dcd15696aac7d7738a8039db603e83"
+)
+noextract=(
+ "lid.176.bin"
+ "lid.176.ftz"
+ )
+
+package() {
+ install -Dm0644 "${srcdir}/lid.176.bin" "${pkgdir}/usr/share/fasttext/lid.176.bin"
+ install -Dm0644 "${srcdir}/lid.176.ftz" "${pkgdir}/usr/share/fasttext/lid.176.ftz"
+}