summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD25
2 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f20e3ac63ad..305b7fb09dba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
# Generated by mksrcinfo v8
-# Fri Feb 24 19:48:11 UTC 2017
+# Fri Oct 20 00:34:46 UTC 2017
pkgbase = fatelf-utils
- pkgdesc = Utils for FatELF - Universal Binaries for Linux
+ pkgdesc = Utils for FatELF universal binaries for Linux
pkgver = 111.5e7e594b70fa
- pkgrel = 2
- url = https://www.icculus.org/fatelf/
+ pkgrel = 3
+ url = https://www.icculus.org/fatelf
arch = i686
arch = x86_64
- license = GPL2
+ license = custom
makedepends = cmake
source = hg+https://hg.icculus.org/icculus/fatelf
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 90ce61850be4..4abe4ea934e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,37 @@
# Maintainer: Gavin Lloyd <gavinhungry@gmail.com>
-# Contributor: Archlive <http://archlive-pkg.googlecode.com>
pkgname=fatelf-utils
-_pkgname=fatelf
pkgver=111.5e7e594b70fa
-pkgrel=2
-pkgdesc='Utils for FatELF - Universal Binaries for Linux'
+pkgrel=3
+pkgdesc='Utils for FatELF universal binaries for Linux'
arch=('i686' 'x86_64')
-url='https://www.icculus.org/fatelf/'
-license=('GPL2')
+url='https://www.icculus.org/fatelf'
+license=('custom')
makedepends=('cmake')
source=('hg+https://hg.icculus.org/icculus/fatelf')
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}"/fatelf
echo $(hg identify -n).$(hg identify -i)
}
build() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}"/fatelf
CFLAGS+=" -O0"
cmake .
make
}
package() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}"/fatelf
- sed -i "s|/usr/local|/usr|g" cmake_install.cmake
+ sed -i 's|/usr/local|/usr|g' cmake_install.cmake
make DESTDIR="${pkgdir}" install
- mkdir -p "${pkgdir}/usr/share/doc/${_pkgname}/"
- install -m644 docs/*.txt "${pkgdir}/usr/share/doc/${_pkgname}/"
+ for FILE in docs/*.txt; do
+ install -Dm644 "$FILE" "${pkgdir}"/usr/share/doc/fatelf/$(basename $FILE)
+ done
+
+ install -Dm644 LICENSE.txt "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}