summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD36
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..34a2fb1e741a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = fatelf-utils
+ pkgdesc = Utils for FatELF - Universal Binaries for Linux
+ pkgver = 108.0a4566740a98
+ pkgrel = 1
+ url = https://www.icculus.org/fatelf/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ source = hg+https://hg.icculus.org/icculus/fatelf
+ md5sums = SKIP
+
+pkgname = fatelf-utils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dfb8f9cb3120
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Gavin Lloyd <gavinhungry@gmail.com>
+# Contributor: Archlive <http://archlive-pkg.googlecode.com>
+
+pkgname=fatelf-utils
+_pkgname=fatelf
+pkgver=108.0a4566740a98
+pkgrel=1
+pkgdesc='Utils for FatELF - Universal Binaries for Linux'
+arch=('i686' 'x86_64')
+url='https://www.icculus.org/fatelf/'
+license=('GPL2')
+makedepends=('cmake')
+source=('hg+https://hg.icculus.org/icculus/fatelf')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ echo $(hg identify -n).$(hg identify -i)
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ CFLAGS+=" -O0"
+ cmake .
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ sed -i "s|/usr/local|/usr|g" cmake_install.cmake
+ make DESTDIR="${pkgdir}" install
+
+ mkdir -p "${pkgdir}/usr/share/doc/${_pkgname}/"
+ install -m644 docs/*.txt "${pkgdir}/usr/share/doc/${_pkgname}/"
+}