summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1daf3ceb0fb3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = fathom-git
+ pkgdesc = Fathom - simple website analytics (Community Edition)
+ pkgver = i.dont.know.what.to.put.here
+ pkgrel = 1
+ url = https://github.com/usefathom/fathom
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = go-pie
+ makedepends = npm
+ provides = fathom
+ conflicts = fathom
+ source = git+https://github.com/usefathom/fathom.git
+ md5sums = SKIP
+
+pkgname = fathom-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de6d9c506d7b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname="fathom-git"
+pkgrel=1
+pkgver="i.dont.know.what.to.put.here"
+pkgdesc="Fathom - simple website analytics (Community Edition)"
+url="https://github.com/usefathom/fathom"
+license=("MIT")
+arch=("any")
+provides=("fathom")
+conflicts=("fathom")
+
+makedepends=("git" "go-pie" "npm")
+
+source=("git+https://github.com/usefathom/fathom.git")
+md5sums=("SKIP")
+_gitname="fathom"
+
+prepare(){
+ mkdir -p gopath/src/github.com/usefathom
+ ln -rTsf "$_gitname" gopath/src/github.com/usefathom/fathom
+ export GOPATH="$srcdir"/gopath
+}
+
+build(){
+ export GOPATH="$srcdir"/gopath
+ cd "$srcdir"/"$_gitname"
+ make build
+}
+
+package(){
+ cd "$srcdir"/"$_gitname"
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+ install -Dm755 fathom "$pkgdir"/usr/bin/fathom
+} \ No newline at end of file