summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--qt4-binary-path.patch11
3 files changed, 25 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 08c590471e59..52c7216facba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fatrat
pkgdesc = Qt Download/Upload Manager
pkgver = 1.2.0_beta2
- pkgrel = 1
+ pkgrel = 2
url = http://fatrat.dolezel.info
arch = i686
arch = x86_64
@@ -9,7 +9,9 @@ pkgbase = fatrat
makedepends = cmake
depends = qt4
source = https://github.com/LubosD/fatrat/archive/1.2.0_beta2.tar.gz
+ source = qt4-binary-path.patch
sha256sums = 187081ad9d6f6f542eab2176c2c00936c7307c08cf903ed752bfc6be13892109
+ sha256sums = da116ae89f82b8cd57e14c91975d3414f4221b1855aa9a9e205fec90ae17564b
pkgname = fatrat
diff --git a/PKGBUILD b/PKGBUILD
index 9bf3a09a4981..4819ccb7f60d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,23 @@
pkgname=fatrat
pkgver=1.2.0_beta2
-pkgrel=1
+pkgrel=2
pkgdesc="Qt Download/Upload Manager"
arch=("i686" "x86_64")
url="http://fatrat.dolezel.info"
license=("custom: GPL2 + complement")
depends=("qt4")
makedepends=("cmake")
-source=("https://github.com/LubosD/fatrat/archive/1.2.0_beta2.tar.gz")
-sha256sums=("187081ad9d6f6f542eab2176c2c00936c7307c08cf903ed752bfc6be13892109")
+source=("https://github.com/LubosD/fatrat/archive/1.2.0_beta2.tar.gz"
+ "qt4-binary-path.patch")
+sha256sums=("187081ad9d6f6f542eab2176c2c00936c7307c08cf903ed752bfc6be13892109"
+ "da116ae89f82b8cd57e14c91975d3414f4221b1855aa9a9e205fec90ae17564b")
+
+prepare() {
+
+ patch -p1 < qt4-binary-path.patch
+
+}
build() {
diff --git a/qt4-binary-path.patch b/qt4-binary-path.patch
new file mode 100644
index 000000000000..ae3b1f418a8d
--- /dev/null
+++ b/qt4-binary-path.patch
@@ -0,0 +1,11 @@
+--- a/fatrat-1.2.0_beta2/CMakeLists.txt 2012-07-14 13:44:27.000000000 +0200
++++ b/fatrat-1.2.0_beta2/CMakeLists.txt 2015-08-24 16:38:12.282592139 +0200
+@@ -654,7 +654,7 @@
+ endif(WITH_JPLUGINS)
+
+ if(WITH_DOCUMENTATION)
+- execute_process(COMMAND qcollectiongenerator
++ execute_process(COMMAND ${QT_QCOLLECTIONGENERATOR_EXECUTABLE}
+ ${CMAKE_CURRENT_SOURCE_DIR}/doc/fatrat.qhcp -o
+ ${CMAKE_CURRENT_SOURCE_DIR}/doc/fatrat.qhc)
+ install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/doc/fatrat.qhc DESTINATION share/fatrat/doc)