summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD39
-rw-r--r--faudio.pc4
3 files changed, 25 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c059e7e01ec..41870384566e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = faudio-git
- pkgdesc = Accuracy-focused XAudio reimplementation for open platforms
- pkgver = r988.911edc7
+ pkgdesc = XAudio2 reimplementation
+ pkgver = 19.05.r13.g3dd4e04
pkgrel = 1
- url = https://github.com/FNA-XNA/FAudio
- arch = i686
+ url = https://github.com/FNA-XNA/FAudio/
arch = x86_64
- license = custom
+ license = custom:zlib
makedepends = git
makedepends = cmake
depends = sdl2
@@ -14,7 +13,7 @@ pkgbase = faudio-git
source = git+https://github.com/FNA-XNA/FAudio
source = faudio.pc
sha256sums = SKIP
- sha256sums = 19dfd14a8d04d88bec136f72486dee3d02f5c9e890abaebe62e1982164764c87
+ sha256sums = f818d65ac8bb142593d87efca3585b0ec9688e79fbed2b5b9ca8c59beb283e7a
pkgname = faudio-git
diff --git a/PKGBUILD b/PKGBUILD
index 94595d102920..a1543b5d455e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,43 @@
# Maintainer: Andrew Whatson <whatson@gmail.com>
_pkgname=faudio
-_gitname=FAudio
pkgname=${_pkgname}-git
-pkgver=r988.911edc7
+pkgver=19.05.r13.g3dd4e04
pkgrel=1
-pkgdesc="Accuracy-focused XAudio reimplementation for open platforms"
-arch=('i686' 'x86_64')
-url='https://github.com/FNA-XNA/FAudio'
-license=('custom')
+pkgdesc="XAudio2 reimplementation"
+arch=(x86_64)
+url="https://github.com/FNA-XNA/FAudio/"
+license=('custom:zlib')
provides=("${_pkgname}")
depends=('sdl2' 'ffmpeg')
makedepends=('git' 'cmake')
source=('git+https://github.com/FNA-XNA/FAudio'
'faudio.pc')
sha256sums=('SKIP'
- '19dfd14a8d04d88bec136f72486dee3d02f5c9e890abaebe62e1982164764c87')
+ 'f818d65ac8bb142593d87efca3585b0ec9688e79fbed2b5b9ca8c59beb283e7a')
pkgver() {
- cd "$srcdir/${_gitname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd FAudio
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-build() {
- mkdir -p "$srcdir/${_gitname}/build"
- cd "$srcdir/${_gitname}/build"
+prepare() {
+ mkdir -p build
+}
- cmake .. \
+build() {
+ cd build
+ cmake ../FAudio \
+ -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr" \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_INSTALL_INCLUDEDIR=include/FAudio \
-DFFMPEG=ON
-
make
}
package() {
- cd "$srcdir/${_gitname}/build"
-
- make install
+ DESTDIR="$pkgdir" make -C build install
- install -D -m644 -t "${pkgdir}/usr/share/licenses/${_pkgname}" ../LICENSE
- install -D -m644 -t "${pkgdir}/usr/lib/pkgconfig" ../../faudio.pc
+ install -Dm644 FAudio/LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
+ install -Dm644 faudio.pc "$pkgdir"/usr/lib/pkgconfig/faudio.pc
}
diff --git a/faudio.pc b/faudio.pc
index 531e11e265af..e54e19d51b9c 100644
--- a/faudio.pc
+++ b/faudio.pc
@@ -1,9 +1,9 @@
prefix=/usr
libdir=${prefix}/lib
-includedir=${prefix}/include/FAudio
+includedir=${prefix}/include
Name: faudio
-Description: Accuracy-focused XAudio reimplementation for open platforms
+Description: XAudio2 reimplementation
Version:
Libs: -L${libdir} -lFAudio