summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--fix-sdl2-config.patch17
3 files changed, 28 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04dce67d16de..bc53c7af7682 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = faudio-wrappers-git
pkgdesc = XAudio2 reimplementation (Windows DLLs)
- pkgver = 19.05.r13.g3dd4e04
+ pkgver = 20.05.r4.g945266a
pkgrel = 1
url = https://github.com/FNA-XNA/FAudio/
arch = i686
@@ -13,8 +13,10 @@ pkgbase = faudio-wrappers-git
depends = wine
depends = winetricks
source = git+https://github.com/FNA-XNA/FAudio
+ source = fix-sdl2-config.patch
source = setup_faudio_aur.verb
sha256sums = SKIP
+ sha256sums = 9712ee4060f5235388e1f709e1629321915e4941772bf5594c05545b10a96e00
sha256sums = 78d4146056bb8b50833580aeacf868040ee36854716c499f5039de1952fb9ca8
pkgname = faudio-wrappers-win32-git
diff --git a/PKGBUILD b/PKGBUILD
index 49d02ef03a33..70c29c2fb5a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _pkgbase=faudio-wrappers
_gitname=FAudio
pkgbase=${_pkgbase}-git
pkgname=("${_pkgbase}-win32-git" "${_pkgbase}-win64-git")
-pkgver=19.05.r13.g3dd4e04
+pkgver=20.05.r4.g945266a
pkgrel=1
pkgdesc="XAudio2 reimplementation (Windows DLLs)"
arch=(i686 x86_64)
@@ -13,8 +13,10 @@ license=('custom:zlib')
depends=('wine' 'winetricks')
makedepends=('git' 'mingw-w64-gcc' 'mingw-w64-sdl2' 'mingw-w64-ffmpeg')
source=('git+https://github.com/FNA-XNA/FAudio'
+ 'fix-sdl2-config.patch'
'setup_faudio_aur.verb')
sha256sums=('SKIP'
+ '9712ee4060f5235388e1f709e1629321915e4941772bf5594c05545b10a96e00'
'78d4146056bb8b50833580aeacf868040ee36854716c499f5039de1952fb9ca8')
pkgver() {
@@ -22,6 +24,11 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$srcdir/${_gitname}"
+ patch -p1 -i ../fix-sdl2-config.patch
+}
+
_build_faudio-wrappers() {
_mingw=$1
diff --git a/fix-sdl2-config.patch b/fix-sdl2-config.patch
new file mode 100644
index 000000000000..65ee61340ba9
--- /dev/null
+++ b/fix-sdl2-config.patch
@@ -0,0 +1,17 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 043fb0b..316c238 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -176,7 +176,11 @@ else()
+ find_package(SDL2 CONFIG)
+ if (TARGET SDL2::SDL2)
+ message(STATUS "using TARGET SDL2::SDL2")
+- target_link_libraries(FAudio PUBLIC SDL2::SDL2)
++ get_target_property(sdl2_location SDL2::SDL2 LOCATION)
++ get_target_property(sdl2_link_libs SDL2::SDL2 INTERFACE_LINK_LIBRARIES)
++ get_target_property(sdl2_include_dirs SDL2::SDL2 INTERFACE_INCLUDE_DIRECTORIES)
++ target_link_libraries(FAudio PUBLIC ${sdl2_location} ${sdl2_link_libs})
++ target_include_directories(FAudio PUBLIC ${sdl2_include_dirs})
+ if(INSTALL_MINGW_DEPENDENCIES)
+ install_shared_libs(TARGETS SDL2::SDL2 DESTINATION bin NO_INSTALL_SYMLINKS REQUIRED)
+ endif()