summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0aa49dd2f8de
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = faustus-rublag-dkms-git
+ pkgdesc = Experimental unofficial Linux platform driver module for ASUS TUF Gaming series laptops with fan mode polling.
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/rublag/faustus
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = dkms
+ conflicts = faustus-dkms-git
+ source = git+https://github.com/hackbnw/faustus.git
+ sha512sums = SKIP
+
+pkgname = faustus-rublag-dkms-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..198def9e9f7e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Chris Cromer <chris@cromer.cl>
+
+pkgname=faustus-rublag-dkms-git
+_pkgname=faustus
+pkgver=0.2
+pkgrel=1
+pkgdesc="Experimental unofficial Linux platform driver module for ASUS TUF Gaming series laptops with fan mode polling."
+arch=("x86_64")
+url="https://github.com/rublag/faustus"
+license=("GPL")
+depends=("dkms")
+makedepends=("git")
+conflicts=("faustus-dkms-git")
+source=("git+https://github.com/hackbnw/faustus.git")
+sha512sums=("SKIP")
+
+pkgver() {
+ source "${srcdir}/${_pkgname}/dkms.conf"
+ echo "${PACKAGE_VERSION}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/src/${_pkgname}-${pkgver}"
+ cp -r ${_pkgname}/* "${pkgdir}"/usr/src/${_pkgname}-${pkgver}/
+
+ install -D <(printf 'blacklist %s\n' "asus_wmi" "asus_nb_wmi") "${pkgdir}/etc/modprobe.d/${_pkgname}.conf"
+ install -D <(printf '%s\n' "${_pkgname}") "${pkgdir}/etc/modules-load.d/${_pkgname}.conf"
+}