summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c21ce9cefe1b..6ec5c6281198 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = fava
pkgdesc = Web interface for beancount
pkgver = 1.6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/beancount/fava
arch = any
license = GPL
- makedepends = npm
depends = beancount
depends = python-click
depends = python-markdown2
depends = python-flask
depends = python-flask-babel
- source = https://github.com/beancount/fava/archive/v1.6.tar.gz
- sha256sums = cef1d26a474a2d6ceeb794ff0a301d22cee409f5ecf8253a4807ff56903f1ebc
+ noextract = fava-1.6-py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py3/f/fava/fava-1.6-py3-none-any.whl
+ sha256sums = 4f9d36f41b3240dded7c3bce930d823733c707aff2e0bc9b64c2ea50445e2f0c
pkgname = fava
diff --git a/PKGBUILD b/PKGBUILD
index 2df5775fd09c..52a31ef3c6ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,16 @@
pkgname='fava'
pkgdesc='Web interface for beancount'
pkgver=1.6
-pkgrel=1
+pkgrel=2
arch=('any')
url='https://github.com/beancount/fava'
license=('GPL')
-source=("https://github.com/beancount/fava/archive/v${pkgver}.tar.gz")
-sha256sums=('cef1d26a474a2d6ceeb794ff0a301d22cee409f5ecf8253a4807ff56903f1ebc')
+source=("https://files.pythonhosted.org/packages/py3/f/fava/fava-${pkgver}-py3-none-any.whl")
+noextract=("fava-${pkgver}-py3-none-any.whl")
+sha256sums=('4f9d36f41b3240dded7c3bce930d823733c707aff2e0bc9b64c2ea50445e2f0c')
depends=('beancount' 'python-click' 'python-markdown2' 'python-flask' 'python-flask-babel')
-makedepends=('npm')
package () {
- cd "${pkgname}-${pkgver}"
- make
- python setup.py install --prefix=/usr --root="${pkgdir}"
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="${pkgdir}" --ignore-installed --no-deps *.whl
+ python -O -m compileall "${pkgdir}/usr/lib/python3.6/site-packages/${pkgname}/"
}