summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffa57cd26b0b..162759116436 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = fava
pkgdesc = Web interface for beancount
pkgver = 1.11
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/beancount/fava
arch = any
license = GPL
+ makedepends = python-pip
depends = beancount
- depends = python-pip
depends = python-click
depends = python-markdown2
depends = python-flask
diff --git a/PKGBUILD b/PKGBUILD
index 1be2fba91cdf..55e84dc64161 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,15 @@
pkgname=fava
pkgdesc='Web interface for beancount'
pkgver=1.11
-pkgrel=2
+pkgrel=3
arch=('any')
url='https://github.com/beancount/fava'
license=('GPL')
source=("https://files.pythonhosted.org/packages/py3/f/fava/fava-${pkgver}-py3-none-any.whl")
noextract=("fava-${pkgver}-py3-none-any.whl")
sha256sums=('1c2f917b240cf49bfd1233a6cd1585175b3f51e2ab83b40dae0f7ee8974f2f3e')
-depends=('beancount' 'python-pip' 'python-click' 'python-markdown2' 'python-flask' 'python-flask-babel' 'python-cheroot')
+depends=('beancount' 'python-click' 'python-markdown2' 'python-flask' 'python-flask-babel' 'python-cheroot')
+makedepends=('python-pip')
package () {
PIP_CONFIG_FILE=/dev/null pip install --isolated --root="${pkgdir}" --ignore-installed --no-deps fava-${pkgver}-py3-none-any.whl