summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af671d91ec04..42ee36dffaa5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fava
pkgdesc = Web interface for beancount
- pkgver = 1.6
- pkgrel = 2
+ pkgver = 1.7
+ pkgrel = 1
url = https://github.com/beancount/fava
arch = any
license = GPL
@@ -11,9 +11,9 @@ pkgbase = fava
depends = python-markdown2
depends = python-flask
depends = python-flask-babel
- noextract = fava-1.6-py3-none-any.whl
- source = https://files.pythonhosted.org/packages/py3/f/fava/fava-1.6-py3-none-any.whl
- sha256sums = 4f9d36f41b3240dded7c3bce930d823733c707aff2e0bc9b64c2ea50445e2f0c
+ noextract = fava-1.7-py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py3/f/fava/fava-1.7-py3-none-any.whl
+ sha256sums = 04f3aae185789392e6ad292731e28bd0fdb00998ed11efafa0328c8e874c111e
pkgname = fava
diff --git a/PKGBUILD b/PKGBUILD
index fd18f6dbb5af..26dfd09bd9c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
pkgname='fava'
pkgdesc='Web interface for beancount'
-pkgver=1.6
-pkgrel=2
+pkgver=1.7
+pkgrel=1
arch=('any')
url='https://github.com/beancount/fava'
license=('GPL')
source=("https://files.pythonhosted.org/packages/py3/f/fava/fava-${pkgver}-py3-none-any.whl")
noextract=("fava-${pkgver}-py3-none-any.whl")
-sha256sums=('4f9d36f41b3240dded7c3bce930d823733c707aff2e0bc9b64c2ea50445e2f0c')
+sha256sums=('04f3aae185789392e6ad292731e28bd0fdb00998ed11efafa0328c8e874c111e')
depends=('beancount' 'python-pip' 'python-click' 'python-markdown2' 'python-flask' 'python-flask-babel')
package () {
- PIP_CONFIG_FILE=/dev/null pip install --isolated --root="${pkgdir}" --ignore-installed --no-deps *.whl
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="${pkgdir}" --ignore-installed --no-deps fava-${pkgver}-py3-none-any.whl
python -O -m compileall "${pkgdir}/usr/lib/python3.6/site-packages/${pkgname}/"
}