summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD20
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31b1d395141e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Tue Jul 5 02:39:30 UTC 2016
+pkgbase = fava
+ pkgdesc = Web interface for beancount
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://aumayr.github.io/fava/
+ arch = any
+ license = GPL
+ depends = beancount
+ depends = python-click
+ depends = python-pygments
+ depends = python-beancount-pygments-lexer
+ depends = python-markdown2
+ depends = python-flask
+ depends = python-flask-babel
+ depends = python-livereload
+ conflicts = beancount-hg
+ source = https://github.com/aumayr/fava/releases/download/v0.3.0/beancount-fava-0.3.0.tar.gz
+ sha256sums = d70ed37a35fa3adeaca519e6eb7ef4ee0b8190dd69f64ce04e8e0b5f15d0bca8
+
+pkgname = fava
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba2613d9ab67
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Zhuoyun Wei <wzyboy@wzyboy.org>
+
+pkgname='fava'
+_pkgname='beancount-fava'
+pkgdesc='Web interface for beancount'
+pkgver=0.3.0
+pkgrel=1
+arch=('any')
+url='https://aumayr.github.io/fava/'
+license=('GPL')
+source=("https://github.com/aumayr/${pkgname}/releases/download/v${pkgver}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('d70ed37a35fa3adeaca519e6eb7ef4ee0b8190dd69f64ce04e8e0b5f15d0bca8')
+depends=('beancount' 'python-click' 'python-pygments' 'python-beancount-pygments-lexer'
+ 'python-markdown2' 'python-flask' 'python-flask-babel' 'python-livereload')
+conflicts=('beancount-hg')
+
+package () {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py install --prefix=/usr --root="${pkgdir}"
+}