summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--fb-adb-git.install9
3 files changed, 5 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff00c379933d..0fd54b98575f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,12 @@
pkgbase = fb-adb-git
pkgdesc = A better shell to use in place of adb when connecting to Android devices
- pkgver = 20151030.r323.a10f1ee
+ pkgver = 20151114.r325.d447d38
pkgrel = 1
url = https://github.com/facebook/fb-adb
- install = fb-adb-git.install
arch = i686
arch = x86_64
license = GPL3
makedepends = git
- makedepends = prelink
makedepends = zip
makedepends = vim
depends = android-tools
diff --git a/PKGBUILD b/PKGBUILD
index e710e308cbfe..2715814a6c54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,19 @@
_pkgname=fb-adb
pkgname=$_pkgname-git
-pkgver=20151030.r323.a10f1ee
+pkgver=20151114.r325.d447d38
pkgrel=1
pkgdesc='A better shell to use in place of adb when connecting to Android devices'
url='https://github.com/facebook/fb-adb'
license=('GPL3')
arch=('i686' 'x86_64')
depends=('android-tools')
-makedepends=('git' 'prelink' 'zip' 'vim')
+makedepends=('git' 'zip' 'vim')
options=('!strip' '!buildflags')
-install=$pkgname.install
-_ndkver=10e
source=("git+$url.git")
sha512sums=('SKIP')
sha512sums=('SKIP')
+_ndkver=10e
[[ -z "$ANDROID_NDK" ]] && {
source_i686+=("android-ndk-r$_ndkver-linux-i686.bin::http://dl.google.com/android/ndk/android-ndk-r$_ndkver-linux-x86.bin")
@@ -30,8 +29,7 @@ pkgver() {
}
build() {
- [[ -z "$ANDROID_NDK" ]] \
- && export ANDROID_NDK="$srcdir/android-ndk-r$_ndkver"
+ [[ -z "$ANDROID_NDK" ]] && export ANDROID_NDK="$srcdir/android-ndk-r$_ndkver"
# configure
cd $_pkgname
@@ -50,7 +48,4 @@ build() {
package() {
install -Dm755 $_pkgname/build/$_pkgname "$pkgdir/usr/bin/$_pkgname"
- install -Dm755 $_pkgname/build/stub-arm/$_pkgname-android-arm.zip "$pkgdir/usr/share/$_pkgname/$_pkgname-android-arm-$pkgver.zip"
- printf '%s\n' "Extract '$_pkgname-android-arm-$pkgver.zip' and copy 'fb-adb' to '/system/bin/fb-adb' on your Android device" \
- > "$pkgdir/usr/share/$_pkgname/README"
}
diff --git a/fb-adb-git.install b/fb-adb-git.install
deleted file mode 100644
index 745582858d1c..000000000000
--- a/fb-adb-git.install
+++ /dev/null
@@ -1,9 +0,0 @@
-post_install(){
- echo "
- NOTE: The fb-adb-android-arm.zip archive contains a build of fb-adb
- compatible with Android devices that have an ARM CPU. To use fb-adb to
- communicate with an Android device, this must be deployed to
- /system/bin/fb-adb (or /system/xbin/fb-adb if the /system/xbin directory is
- used by the ROM)
- "
-}