summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7c69c93374e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = fbgetty
+ pkgdesc = fbgetty is a console getty like mingetty, which supports framebuffers
+ pkgver = 0.1.698
+ pkgrel = 5
+ url = http://projects.meuh.org/fbgetty
+ arch = x86_64
+ license = GPL
+ source = http://projects.meuh.org/fbgetty/downloads/fbgetty-0.1.698.tar.gz
+ source = http://projects.meuh.org/fbgetty/downloads/fbgetty-0.1.698.tar.gz.sig
+ sha256sums = 332cbffa7c489b39a7d13d12d581c27dfc57ba098041431a6845b44785cf2d35
+ sha256sums = SKIP
+
+pkgname = fbgetty
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0dcb4f6777ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+
+pkgname=fbgetty
+pkgver=0.1.698
+pkgrel=5
+license=("GPL")
+pkgdesc="fbgetty is a console getty like mingetty, which supports framebuffers"
+arch=('x86_64')
+url="http://projects.meuh.org/fbgetty"
+source=('http://projects.meuh.org/fbgetty/downloads/fbgetty-'$pkgver'.tar.gz'{,.sig})
+sha256sums=('332cbffa7c489b39a7d13d12d581c27dfc57ba098041431a6845b44785cf2d35'
+ 'SKIP')
+
+build()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+
+ ./configure --prefix=/usr --mandir=/usr/share/man --sbindir=/usr/bin
+
+ patch src/options.c <<EOF
+33a34
+> #include <stddef.h>
+EOF
+
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ mv "$pkgdir"/usr/info "$pkgdir"/usr/share/
+}