summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD38
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..754723ada994
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = fceux-git
+ pkgdesc = Fast and ultra-compatible NES/Famicom emulator with SDL, OpenGL and SVGALIB support
+ pkgver = e8c61d1b
+ pkgrel = 1
+ url = http://fceux.com/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = scons
+ makedepends = libgl
+ makedepends = glu
+ depends = sdl
+ depends = lua51
+ depends = gtk2
+ depends = gd
+ depends = libgl
+ optdepends = xchm: for viewing the help manual
+ provides = fceux
+ conflicts = fceux
+ source = git://github.com/TASVideos/fceux.git
+ md5sums = SKIP
+
+pkgname = fceux-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..683a1681ca79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Lukas Sabota <LTsmooth42 _at_ gmail _dot_ com>
+
+pkgname=fceux-git
+pkgver=e8c61d1b
+pkgrel=1
+pkgdesc="Fast and ultra-compatible NES/Famicom emulator with SDL, OpenGL and SVGALIB support"
+arch=('i686' 'x86_64')
+url="http://fceux.com/"
+license=('GPL')
+depends=('sdl' 'lua51' 'gtk2' 'gd' 'libgl')
+makedepends=('git' 'scons' 'libgl' 'glu')
+optdepends=('xchm: for viewing the help manual')
+provides=('fceux')
+conflicts=('fceux')
+source=(git://github.com/TASVideos/fceux.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd fceux
+ git describe --always| sed 's/-/./g'
+}
+
+
+build() {
+ cd fceux
+
+ scons RELEASE=1
+}
+
+package() {
+ cd fceux
+
+ install -D -m755 bin/fceux "$pkgdir/usr/bin/fceux"
+ install -D -m755 bin/fceux-net-server "$pkgdir/usr/bin/fceux-net-server"
+ install -D -m644 bin/fceux.chm "$pkgdir/usr/share/doc/fceux/fceux.chm"
+ install -D -m644 "fceux.desktop" "$pkgdir/usr/share/applications/fceux.desktop"
+ install -D -m644 "fceux.png" "$pkgdir/usr/share/pixmaps/fceux.png"
+}