summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD34
2 files changed, 25 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18313407363f..0940c41af897 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = fcitx-chewing-git
pkgdesc = Fcitx Wrapper for chewing
pkgver = 0.2.3.r4.ge4bb273
- pkgrel = 3
+ pkgrel = 4
url = https://gitlab.com/fcitx/fcitx-chewing
arch = i686
arch = x86_64
- license = GPL
+ license = GPL2
makedepends = cmake
makedepends = git
depends = libchewing-git
depends = fcitx
- provides = fcitx-chewing
+ provides = fcitx-chewing=0.2.3.r4.ge4bb273
conflicts = fcitx-chewing
source = git+https://gitlab.com/fcitx/fcitx-chewing.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 2c6cec10e4c3..61471f6dfa59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,47 @@
-# $Id$
-# Maintainer: Felix Yan <felixonmars@gmail.com>
+# Maintainer: Chih-Hsuan Yen <yan12125@gmail.com>
+# Forked from community/fcitx-chewing; original contributors:
+# Contributor: Felix Yan <felixonmars@gmail.com>
_pkgname=fcitx-chewing
-pkgname=${_pkgname}-git
+pkgname=$_pkgname-git
pkgver=0.2.3.r4.ge4bb273
-pkgrel=3
+pkgrel=4
pkgdesc='Fcitx Wrapper for chewing'
arch=(i686 x86_64)
url='https://gitlab.com/fcitx/fcitx-chewing'
-license=(GPL)
+license=(GPL2)
depends=(libchewing-git fcitx)
makedepends=(cmake git)
source=("git+https://gitlab.com/fcitx/fcitx-chewing.git")
md5sums=('SKIP')
-conflicts=("${_pkgname}")
-provides=("${_pkgname}")
+conflicts=("$_pkgname")
+provides=("$_pkgname=$pkgver")
pkgver() {
cd $_pkgname
( set -o pipefail
- git describe --long --tag 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tag 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
)
}
+prepare() {
+ cd $_pkgname
+
+ mkdir -p build
+}
+
build() {
- cd ${_pkgname}
+ cd $_pkgname/build
+
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ ..
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release .
make
}
package() {
- cd ${_pkgname}
+ cd $_pkgname/build
+
make DESTDIR="$pkgdir" install
}