summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD50
2 files changed, 41 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39d592374708..14fb68a73e70 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = fcitx-mozc-neologd-ut+ut2
pkgver = 2.23.2815.102.20200521.20171008
- pkgrel = 1
+ pkgrel = 2
url = https://osdn.net/users/utuhiro/pf/utuhiro/files/
arch = i686
arch = x86_64
license = custom
makedepends = clang
makedepends = gyp
- makedepends = protobuf
makedepends = ninja
makedepends = pkg-config
makedepends = python
@@ -20,27 +19,28 @@ pkgbase = fcitx-mozc-neologd-ut+ut2
makedepends = glib2
makedepends = bzip2
makedepends = unzip
- depends = protobuf
- source = mozc-2.23.2815.102+dfsg.tar.xz::http://ftp.jp.debian.org/debian/pool/main/m/mozc/mozc_2.23.2815.102+dfsg.orig.tar.xz
- source = japanese_usage_dictionary::git+https://github.com/hiroyuki-komatsu/japanese-usage-dictionary.git#commit=
- source = fix-build-with-gcc8.patch::https://salsa.debian.org/debian/mozc/raw/master/debian/patches/Fix-build-with-gcc8.patch
- source = mozc-2.23.2815.102-python-3.patch::https://github.com/google/mozc/files/4048079/mozc-2.23.2815.102-python-3.patch.txt
- source = add_support_new_japanese_era_for_mozc.patch
- source = add_support_new_japanese_era_for_ut2.patch
+ source = http://ftp.jp.debian.org/debian/pool/main/m/mozc/mozc_2.23.2815.102+dfsg.orig.tar.xz
+ source = protobuf-3.5.2.tar.gz::https://github.com/protocolbuffers/protobuf/archive/v3.5.2.tar.gz
+ source = https://salsa.debian.org/debian/mozc/-/raw/master/debian/patches/usage_dict.txt.patch
+ source = https://salsa.debian.org/debian/mozc/-/raw/master/debian/patches/Fix-build-with-gcc8.patch
+ source = https://salsa.debian.org/debian/mozc/-/raw/master/debian/patches/Change-from-python2-code-to-python3.patch
source = https://download.fcitx-im.org/fcitx-mozc/fcitx-mozc-2.23.2815.102.1.patch
source = https://download.fcitx-im.org/fcitx-mozc/fcitx-mozc-icon.tar.gz
source = https://osdn.net/users/trickart/pf/trickart_pkgbuild/dl/mozc-neologd-ut/mozcdic-neologd-ut-20200521.1.tar.bz2
source = https://osdn.net/downloads/users/26/26381/mozc-ut2-2.20.2677.102.20171008.tar.xz
+ source = add_support_new_japanese_era_for_mozc.patch
+ source = add_support_new_japanese_era_for_ut2.patch
sha1sums = 7e0a39ffd5ea68ecadb792fc521c16b5be1f25cb
- sha1sums = SKIP
+ sha1sums = d0c551031828ed9c07cc683762353a67b1a17627
+ sha1sums = c6f5aac79c7e98fbda96de251d8f0d0787344ca9
sha1sums = 4fe935b5c2d316119cf8957b6518b3b5e7bf6ecf
- sha1sums = 1b281471dac2eeab6d9ad7c47e3929e1ac402344
- sha1sums = ea8df0fc171c321457bd0692795f0c61c7ee04ce
- sha1sums = fa72a89ac18649816e9717d4468a6145db802625
+ sha1sums = SKIP
sha1sums = 63a2b10e7d209c6216e2d912b2629efc44c637ea
sha1sums = 883f4fc489a9ed1c07d2d2ec37ca72509f04ea5d
sha1sums = c09d1da0445868474ed0dae2b580d17dbc2f5364
sha1sums = 3ac129c9cd843c51a3e0a124a47cfb8eddab2c08
+ sha1sums = ea8df0fc171c321457bd0692795f0c61c7ee04ce
+ sha1sums = fa72a89ac18649816e9717d4468a6145db802625
pkgname = mozc-neologd-ut+ut2
pkgdesc = A Japanese Input Method for Chromium OS, Windows, Mac and Linux (the Open Source Edition of Google Japanese Input)
@@ -54,6 +54,7 @@ pkgname = mozc-neologd-ut+ut2
conflicts = mozc-ut2
conflicts = fcitx-mozc-ut
conflicts = mozc-ut
+ conflicts = mozc-neologd-ut
conflicts = fcitx-mozc-neologd-ut
pkgname = fcitx-mozc-neologd-ut+ut2
diff --git a/PKGBUILD b/PKGBUILD
index f9f2bf37224a..07b1c6c02aa1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,41 +14,42 @@ _neologdrel=1
_ut2mozcver=2.20.2677.102
_ut2dicver=20171008
pkgver=${_mozcver}.${_neologddate}.${_ut2dicver}
-pkgrel=1
+pkgrel=2
pkgbase=fcitx-mozc-neologd-ut+ut2
-pkgname=fcitx-mozc-neologd-ut+ut2
+pkgname=${pkgbase}
true && pkgname=('mozc-neologd-ut+ut2' 'fcitx-mozc-neologd-ut+ut2')
arch=('i686' 'x86_64')
url="https://osdn.net/users/utuhiro/pf/utuhiro/files/"
license=('custom')
-depends=('protobuf')
-makedepends=('clang' 'gyp' 'protobuf' 'ninja' 'pkg-config' 'python' 'curl' 'gtk2' 'qt5-base' 'zinnia' 'fcitx' 'libxcb' 'glib2' 'bzip2' 'unzip')
+makedepends=('clang' 'gyp' 'ninja' 'pkg-config' 'python' 'curl' 'gtk2' 'qt5-base' 'zinnia' 'fcitx' 'libxcb' 'glib2' 'bzip2' 'unzip')
source=(
- mozc-${_mozcver}+dfsg.tar.xz::http://ftp.jp.debian.org/debian/pool/main/m/mozc/mozc_${_mozcver}+dfsg.orig.tar.xz
- japanese_usage_dictionary::git+https://github.com/hiroyuki-komatsu/japanese-usage-dictionary.git#commit=${_japanese_usage_dictionary_rev}
- fix-build-with-gcc8.patch::https://salsa.debian.org/debian/mozc/raw/master/debian/patches/Fix-build-with-gcc8.patch
- mozc-2.23.2815.102-python-3.patch::https://github.com/google/mozc/files/4048079/mozc-2.23.2815.102-python-3.patch.txt
- add_support_new_japanese_era_for_mozc.patch
- add_support_new_japanese_era_for_ut2.patch
+ http://ftp.jp.debian.org/debian/pool/main/m/mozc/mozc_${_mozcver}+dfsg.orig.tar.xz
+ protobuf-3.5.2.tar.gz::https://github.com/protocolbuffers/protobuf/archive/v3.5.2.tar.gz
+ https://salsa.debian.org/debian/mozc/-/raw/master/debian/patches/usage_dict.txt.patch
+ https://salsa.debian.org/debian/mozc/-/raw/master/debian/patches/Fix-build-with-gcc8.patch
+ https://salsa.debian.org/debian/mozc/-/raw/master/debian/patches/Change-from-python2-code-to-python3.patch
https://download.fcitx-im.org/fcitx-mozc/fcitx-mozc-${_fcitxver}.patch
https://download.fcitx-im.org/fcitx-mozc/fcitx-mozc-icon.tar.gz
https://osdn.net/users/trickart/pf/trickart_pkgbuild/dl/mozc-neologd-ut/mozcdic-neologd-ut-${_neologddate}.${_neologdrel}.tar.bz2
"https://osdn.net/downloads/users/26/26381/mozc-ut2-2.20.2677.102.20171008.tar.xz"
+ add_support_new_japanese_era_for_mozc.patch
+ add_support_new_japanese_era_for_ut2.patch
)
sha1sums=(
'7e0a39ffd5ea68ecadb792fc521c16b5be1f25cb'
- 'SKIP'
+ 'd0c551031828ed9c07cc683762353a67b1a17627'
+ 'c6f5aac79c7e98fbda96de251d8f0d0787344ca9'
'4fe935b5c2d316119cf8957b6518b3b5e7bf6ecf'
- '1b281471dac2eeab6d9ad7c47e3929e1ac402344'
- 'ea8df0fc171c321457bd0692795f0c61c7ee04ce'
- 'fa72a89ac18649816e9717d4468a6145db802625'
+ 'SKIP'
'63a2b10e7d209c6216e2d912b2629efc44c637ea'
'883f4fc489a9ed1c07d2d2ec37ca72509f04ea5d'
'c09d1da0445868474ed0dae2b580d17dbc2f5364'
'3ac129c9cd843c51a3e0a124a47cfb8eddab2c08'
+ 'ea8df0fc171c321457bd0692795f0c61c7ee04ce'
+ 'fa72a89ac18649816e9717d4468a6145db802625'
)
prepare() {
@@ -59,23 +60,26 @@ prepare() {
cp -f $srcdir/mozc-ut2-${_ut2mozcver}.${_ut2dicver}/src/data/dictionary_oss/dictionary*.txt $srcdir/mozc-${_mozcver}+dfsg/src/data/dictionary_oss/
cd mozc-${_mozcver}+dfsg
- patch -Np1 -i ${srcdir}/fix-build-with-gcc8.patch
- patch -Np1 -i ${srcdir}/mozc-2.23.2815.102-python-3.patch
+ mkdir -p src/third_party
+ mv ${srcdir}/protobuf-3.5.2 src/third_party/protobuf
+ patch -Np1 -i ${srcdir}/usage_dict.txt.patch
+ patch -Np1 -i ${srcdir}/Fix-build-with-gcc8.patch
+ patch -Np1 -i ${srcdir}/Change-from-python2-code-to-python3.patch
patch -Np1 -i ${srcdir}/fcitx-mozc-${_fcitxver}.patch
- mkdir -p src/third_party/
- cp -a ${srcdir}/japanese_usage_dictionary src/third_party/
+
+ # Avoid fcitx5 build errors
+ rm -rf src/unix/fcitx5/
+
+ # Add a neologd dictionary
cat ${srcdir}/mozcdic-neologd-ut-${_neologddate}.${_neologdrel}/mozcdic-*-ut-*.txt >> src/data/dictionary_oss/dictionary00.txt
}
build() {
cd mozc-${_mozcver}+dfsg/src
- # Avoid fcitx5 build errors
- rm -rf unix/fcitx5/
-
_targets="server/server.gyp:mozc_server gui/gui.gyp:mozc_tool renderer/renderer.gyp:mozc_renderer unix/fcitx/fcitx.gyp:fcitx-mozc unix/fcitx/fcitx.gyp:gen_fcitx_mozc_i18n"
- GYP_DEFINES="use_libprotobuf=1 use_libzinnia=1 document_dir=/usr/share/licenses/mozc" python build_mozc.py gyp --gypdir=/usr/bin --target_platform=Linux
+ GYP_DEFINES="use_libzinnia=1 document_dir=/usr/share/licenses/mozc" python build_mozc.py gyp --gypdir=/usr/bin --target_platform=Linux
python build_mozc.py build -c $_bldtype $_targets
}
@@ -83,7 +87,7 @@ package_mozc-neologd-ut+ut2() {
pkgdesc="A Japanese Input Method for Chromium OS, Windows, Mac and Linux (the Open Source Edition of Google Japanese Input)"
arch=('i686' 'x86_64')
depends=('qt5-base' 'zinnia')
- conflicts=('fcitx-mozc' 'mozc' 'fcitx-mozc-ut2' 'mozc-ut2' 'fcitx-mozc-ut' 'mozc-ut' 'fcitx-mozc-neologd-ut')
+ conflicts=('fcitx-mozc' 'mozc' 'fcitx-mozc-ut2' 'mozc-ut2' 'fcitx-mozc-ut' 'mozc-ut' 'mozc-neologd-ut' 'fcitx-mozc-neologd-ut')
cd mozc-${_mozcver}+dfsg/src
install -D -m 755 out_linux/${_bldtype}/mozc_server "${pkgdir}/usr/lib/mozc/mozc_server"
install -m 755 out_linux/${_bldtype}/mozc_tool "${pkgdir}/usr/lib/mozc/mozc_tool"