summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a623e9e4985
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = fcitx5-skin-microsoft_style
+ pkgdesc = A ssf to fcitx5 skin ,made by ssfconv.
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/zzy-ac/fcitx5-skin-microsoft-style
+ arch = any
+ license = Apache
+ depends = fcitx5
+ source = https://github.com/zzy-ac/fcitx5-skin-microsoft-style/raw/main/Microsoft-style.tar.gz
+ md5sums = c61c92766ced53482d91b301c7347f7c
+
+pkgname = fcitx5-skin-microsoft_style
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b039afe8e04a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Xuanrui Qi <me@xuanruiqi.com>
+# Contributor: whriedplanck
+# Contributor: HRKo <hrko[at]r-c.dev>
+
+pkgname=fcitx5-skin-microsoft_style
+pkgver=0.1
+pkgrel=1
+pkgdesc="A ssf to fcitx5 skin ,made by ssfconv."
+arch=('any')
+url="https://github.com/zzy-ac/fcitx5-skin-microsoft-style"
+license=('Apache')
+depends=('fcitx5')
+source=("$url/raw/main/Microsoft-style.tar.gz")
+md5sums=('c61c92766ced53482d91b301c7347f7c')
+
+package() {
+ _variant_name=Microsoft-style
+ cd ${srcdir}
+ cd $_variant_name
+
+ install -dm755 "${pkgdir}"/usr/share/fcitx5/themes/$_variant_name
+ install -m644 ./* "$pkgdir"/usr/share/fcitx5/themes/$_variant_name
+}