summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
-rw-r--r--fdc3-sail.sh6
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..62e6e1dd92d1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = fdc3-sail-bin
+ pkgdesc = Open implementation of the FDC3 standard using Electron and an integrated App Directory.
+ pkgver = 22.12.6.1030
+ pkgrel = 1
+ url = https://github.com/finos/FDC3-Sail
+ arch = x86_64
+ license = Apache
+ depends = electron24
+ depends = hicolor-icon-theme
+ conflicts = fdc3-sail
+ source = fdc3-sail-22.12.6.1030.AppImage::https://github.com/finos/FDC3-Sail/releases/download/v22.12.6-1030/FDC3-Sail-22.12.6-1030.AppImage
+ source = fdc3-sail.sh
+ sha256sums = 81243023ba6af8562e5244f6d48f2e4dd8f17ab77984dda7a55ad0863959ea97
+ sha256sums = fdc1caaf3e4f54c9a4dd60923e35e521a31884ae39b2dd0291b85baaba899ff7
+
+pkgname = fdc3-sail-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5f66acb1ad0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname="fdc3-sail-bin"
+pkgver=22.12.6.1030
+_appver=22.12.6-1030
+pkgrel=1
+pkgdesc="Open implementation of the FDC3 standard using Electron and an integrated App Directory."
+arch=('x86_64')
+url="https://github.com/finos/FDC3-Sail"
+license=('Apache')
+conflicts=("${pkgname%-bin}")
+depends=('electron24' 'hicolor-icon-theme')
+source=("${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/v${_appver}/FDC3-Sail-${_appver}.AppImage"
+ "${pkgname%-bin}.sh")
+sha256sums=('81243023ba6af8562e5244f6d48f2e4dd8f17ab77984dda7a55ad0863959ea97'
+ 'fdc1caaf3e4f54c9a4dd60923e35e521a31884ae39b2dd0291b85baaba899ff7')
+prepare() {
+ chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
+ "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
+}
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.asar"
+ for _icons in 16x16 32x32 48x48 64x64 128x128 256x256 512x512 1024x1024;do
+ install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
+ -t "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps"
+ done
+ sed "s|AppRun --no-sandbox %U|/opt/${pkgname%-bin}/${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+} \ No newline at end of file
diff --git a/fdc3-sail.sh b/fdc3-sail.sh
new file mode 100644
index 000000000000..a7b574433f2d
--- /dev/null
+++ b/fdc3-sail.sh
@@ -0,0 +1,6 @@
+#!/bin/bash
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec electron24 /opt/fdc3-sail/fdc3-sail.asar "$@"
+else
+ exec electron24 --no-sandbox /opt/fdc3-sail/fdc3-sail.asar "$@"
+fi \ No newline at end of file