aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--Makefile2
-rw-r--r--PKGBUILD5
3 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b1ccbdeb263..eb111257934c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fe
pkgdesc = AUR helper with a familiar subcommand system
- pkgver = 1.0.13
+ pkgver = 1.0.14
pkgrel = 1
url = https://github.com/baris-inandi/fe
arch = x86_64
@@ -10,6 +10,8 @@ pkgbase = fe
depends = bash
depends = sudo
depends = paru
+ backup = etc/feparu.conf
+ backup = etc/fepacman.conf
source = git+https://github.com/baris-inandi/fe
md5sums = SKIP
diff --git a/Makefile b/Makefile
index 15832aaa8725..cb2ae46a106a 100644
--- a/Makefile
+++ b/Makefile
@@ -11,7 +11,9 @@ in:
make clean
make srcinfo
make si
+ make clean
prep:
make clean
make srcinfo
+ make clean
diff --git a/PKGBUILD b/PKGBUILD
index 78a185244294..c9aaa94e98f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
Maintainer="baris-inandi"
pkgname=fe
-pkgver=1.0.13
+pkgver=1.0.14
pkgrel=1
pkgdesc="AUR helper with a familiar subcommand system"
arch=(x86_64)
@@ -10,6 +10,7 @@ depends=(bash sudo paru)
makedepends=(git go)
source=("git+$url")
md5sums=('SKIP')
+backup=("etc/feparu.conf" "etc/fepacman.conf")
build() {
cd "$pkgname"
@@ -23,5 +24,7 @@ build() {
package() {
cd "$pkgname"
+ install -Dm644 conf/pacman.conf "$pkgdir"/etc/fepacman.conf
+ install -Dm644 conf/paru.conf "$pkgdir"/etc/feparu.conf
install -Dm755 "$pkgname-$pkgver-$pkgrel" "$pkgdir"/usr/bin/$pkgname
}