summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37cd0f069468..78375ba07485 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = feathernotes-git
pkgdesc = Lightweight Qt hierarchical notes-manager for Linux.
- pkgver = 0.10.0.10.gf0a367c
+ pkgver = 0.10.0.14.g9cb610a
pkgrel = 1
url = https://github.com/tsujan/feathernotes
arch = i686
@@ -8,13 +8,12 @@ pkgbase = feathernotes-git
license = GPL3
makedepends = git
makedepends = cmake
- makedepends = qt5-tools
- depends = qt5-x11extras
- depends = qt5-svg
+ makedepends = qt6-tools
+ depends = qt6-svg
depends = shared-mime-info
depends = desktop-file-utils
depends = hunspell
- optdepends = qt5-translations: localized keyboard shortcuts
+ optdepends = qt6-translations: localized keyboard shortcuts
provides = feathernotes
conflicts = feathernotes
source = feathernotes::git+https://github.com/tsujan/feathernotes.git
diff --git a/PKGBUILD b/PKGBUILD
index be8ddad139ed..68aad3c03814 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
_pkgname=feathernotes
pkgname=$_pkgname-git
-pkgver=0.10.0.10.gf0a367c
+pkgver=0.10.0.14.g9cb610a
pkgrel=1
pkgdesc='Lightweight Qt hierarchical notes-manager for Linux.'
arch=('i686' 'x86_64')
url='https://github.com/tsujan/feathernotes'
license=('GPL3')
-depends=('qt5-x11extras' 'qt5-svg' 'shared-mime-info' 'desktop-file-utils' 'hunspell')
-makedepends=('git' 'cmake' 'qt5-tools')
-optdepends=('qt5-translations: localized keyboard shortcuts')
+depends=('qt6-svg' 'shared-mime-info' 'desktop-file-utils' 'hunspell')
+makedepends=('git' 'cmake' 'qt6-tools')
+optdepends=('qt6-translations: localized keyboard shortcuts')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("$_pkgname::git+${url}.git")
@@ -24,7 +24,7 @@ pkgver() {
build() {
rm -Rf build && mkdir build
cd build
- cmake $srcdir/$_pkgname/
+ cmake $srcdir/$_pkgname/ -DENABLE_QT5=OFF
make
}