summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD33
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..838888f8ba09
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Wed Oct 5 15:33:28 UTC 2016
+pkgbase = featherpad-git
+ pkgdesc = Lightweight Qt5 plain text editor for Linux
+ pkgver = r33.a89933d
+ pkgrel = 1
+ url = https://github.com/tsujan/FeatherPad
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = qt5-svg
+ depends = qt5-x11extras
+ depends = desktop-file-utils
+ depends = gtk-update-icon-cache
+ provides = featherpad
+ conflicts = featherpad
+ source = featherpad::git+https://github.com/tsujan/FeatherPad.git
+ sha256sums = SKIP
+
+pkgname = featherpad-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0431e10008bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Peter Mattern <pmattern at arcor dot de>
+
+_pkgname=featherpad
+pkgname=$_pkgname-git
+pkgver=r33.a89933d
+pkgrel=1
+pkgdesc='Lightweight Qt5 plain text editor for Linux'
+arch=('i686' 'x86_64')
+url='https://github.com/tsujan/FeatherPad'
+license=('GPL3')
+depends=('qt5-svg' 'qt5-x11extras' 'desktop-file-utils' 'gtk-update-icon-cache')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+https://github.com/tsujan/FeatherPad.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd $_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ rm -Rf build && mkdir build
+ cd build
+ qmake $srcdir/$_pkgname/ CONFIG+=debug
+ make
+}
+
+package() {
+ cd build
+ make INSTALL_ROOT=$pkgdir install
+}