summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD19
3 files changed, 22 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bdf4e69998db..146e66dc5cf7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = feedgnuplot
- pkgdesc = General purpose pipe-oriented plotting tool
- pkgver = 1.54
+ pkgdesc = Tool to plot realtime and stored data from the commandline, using gnuplot.
+ pkgver = 1.62
pkgrel = 1
url = https://github.com/dkogan/feedgnuplot
arch = any
@@ -10,8 +10,7 @@ pkgbase = feedgnuplot
depends = perl-list-moreutils
depends = perl-string-shellquote
provides = feedgnuplot
- source = https://github.com/dkogan/feedgnuplot/archive/v1.54.tar.gz
- sha256sums = 5549e97d53a813e87938d73339df0dc858072ae5dff388541428741c9becb512
+ source = https://github.com/dkogan/feedgnuplot/archive/v1.62.tar.gz
+ b2sums = 3bbc5c45aa23437c952daf669f312505af89f18144cd6318369de45058898b863ac9e1cfd82f9f4695b5c608f1416b7ab97b51db836d3b08b85cbbff85d29269
pkgname = feedgnuplot
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..16c18c6136ce
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/pkg
+/src
+
diff --git a/PKGBUILD b/PKGBUILD
index 4621bab1ddf4..238adae27fe7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Dmitri Kourennyi <dkour at mykolab dot com>
# Contributor: Eric Schulte <[firstname] dot [lastname] at gmx dot com>
pkgname=feedgnuplot
-pkgver=1.54
+pkgver=1.62
pkgrel=1
-pkgdesc="General purpose pipe-oriented plotting tool"
+pkgdesc="Tool to plot realtime and stored data from the commandline, using gnuplot."
arch=('any')
url="https://github.com/dkogan/feedgnuplot"
license=('GPL')
depends=('perl' 'gnuplot' 'perl-list-moreutils' 'perl-string-shellquote')
provides=('feedgnuplot')
-source=("https://github.com/dkogan/feedgnuplot/archive/v${pkgver}.tar.gz")
-sha256sums=("5549e97d53a813e87938d73339df0dc858072ae5dff388541428741c9becb512")
+source=("https://github.com/dkogan/${pkgname}/archive/v${pkgver}.tar.gz")
+b2sums=("3bbc5c45aa23437c952daf669f312505af89f18144cd6318369de45058898b863ac9e1cfd82f9f4695b5c608f1416b7ab97b51db836d3b08b85cbbff85d29269")
build() {
cd "$srcdir/${pkgname}-${pkgver}" || exit
@@ -28,4 +28,15 @@ package() {
unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+
+ # Copy shell completions
+ install -D --mode=644 --target-directory="$pkgdir/usr/share/bash-completion/completions/" completions/bash/feedgnuplot
+ install -D --mode=644 --target-directory="$pkgdir/usr/share/zsh/site-functions/" completions/zsh/_feedgnuplot
+
+ # Copy guide
+ install --directory "$pkgdir/usr/share/doc/feedgnuplot"
+ cp --recursive guide "$pkgdir/usr/share/doc/feedgnuplot/"
+
+ # Copy License
+ install -D --mode=644 --target-directory="$pkgdir/usr/share/licenses/feedgnuplot/" LICENSE
}