summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4eb630652345
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = feedgnuplot
+ pkgdesc = Pipe-oriented frontend to Gnuplot
+ pkgver = 1.44
+ pkgrel = 1
+ url = https://github.com/dkogan/feedgnuplot
+ arch = any
+ license = GPL
+ depends = perl
+ depends = gnuplot
+ depends = perl-list-moreutils
+ depends = perl-string-shellquote
+ provides = feedgnuplot
+ source = https://github.com/dkogan/feedgnuplot/archive/v1.44.tar.gz
+ md5sums = 03c73ea12f51deb591198147330377fc
+
+pkgname = feedgnuplot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d9ebd9b6dc8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# -*- shell-script -*-
+# Maintainer: Dmitri Kourennyi <dkour at mykolab dot com>
+# Contributor: Eric Schulte <[firstname] dot [lastname] at gmx dot com>
+pkgname=feedgnuplot
+pkgver=1.44
+pkgrel=1
+pkgdesc="Pipe-oriented frontend to Gnuplot"
+arch=('any')
+url="https://github.com/dkogan/feedgnuplot"
+license=('GPL')
+depends=('perl' 'gnuplot' 'perl-list-moreutils' 'perl-string-shellquote')
+provides=(feedgnuplot)
+source=("https://github.com/dkogan/feedgnuplot/archive/v${pkgver}.tar.gz")
+md5sums=("03c73ea12f51deb591198147330377fc")
+
+build() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+
+ /usr/bin/perl Makefile.PL
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+}