summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD44
2 files changed, 26 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffa2afc3ff90..d06256617719 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sat May 5 10:45:37 UTC 2018
pkgbase = feelpp
pkgdesc = Finite Element Embedded Language and Library in C++
- pkgver = 0.104.0
+ pkgver = 0.106.0_beta.2
pkgrel = 1
url = https://github.com/feelpp
arch = i686
@@ -21,8 +19,8 @@ pkgbase = feelpp
depends = gsl
depends = python
depends = ginac
- source = https://github.com/feelpp/feelpp/releases/download/v0.104.0/feelpp-0.104.0.tar.gz
- sha256sums = 380ff2712c01740460ecef4326fa790f5daee8bc79a8d3359d1a61099e32d533
+ source = https://github.com/feelpp/feelpp/archive/v0.106.0-beta.2.tar.gz
+ sha256sums = f95c3c0c10fccb3f95ad9b0279580e7422bd8ef4a0b8339417cdb67415b10fa5
pkgname = feelpp
diff --git a/PKGBUILD b/PKGBUILD
index 108908d67cde..1de4f69f706c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: George Eleftheriou <eleftg>
pkgname='feelpp'
-pkgver=0.104.0
+pkgver=0.106.0_beta.2
pkgrel=1
pkgdesc="Finite Element Embedded Language and Library in C++"
arch=('i686' 'x86_64')
@@ -11,17 +11,28 @@ license=('LGPL')
depends=('cln' 'mumps' 'slepc' 'gmsh' 'fftw' 'ann' 'libbson' 'glpk' 'gsl' 'python' 'ginac')
makedepends=('cmake' 'python2')
source=("https://github.com/feelpp/feelpp/releases/download/v${pkgver}/feelpp-${pkgver}.tar.gz")
-sha256sums=('380ff2712c01740460ecef4326fa790f5daee8bc79a8d3359d1a61099e32d533')
+source=(https://github.com/feelpp/feelpp/archive/v${pkgver/_/-}.tar.gz)
+sha256sums=('f95c3c0c10fccb3f95ad9b0279580e7422bd8ef4a0b8339417cdb67415b10fa5')
prepare() {
- cd $pkgbase-$pkgver
+ cd $pkgbase-${pkgver/_/-}
- # https://github.com/feelpp/feelpp/issues/1096
- grep -lr 'COMMAND python' contrib/ginac|xargs sed -i "s|COMMAND python |COMMAND python2 |g"
+ # https://github.com/feelpp/feelpp/issues/1247: boost 1.68 support
+ curl -L https://github.com/feelpp/feelpp/commit/f5951158541f664a31d7e8b2d460f3bde7d26e51.patch | patch -p1
+ curl -L https://github.com/feelpp/feelpp/commit/a10192595eea7895dfc0d9faabff48b8086b6cf7.patch | patch -p1
+ curl -L https://github.com/feelpp/feelpp/commit/d0df2512cb56c838e2a27bc6721b63395ada5a21.patch | patch -p1
+ curl -L https://github.com/feelpp/feelpp/pull/1251.patch | patch -p1
+
+ # git submodules not included in tarball
+ test -f feelpp/contrib/pybind11/CMakeLists.txt || git clone https://github.com/feelpp/pybind11.git feelpp/contrib/pybind11
+ test -f feelpp/contrib/nlopt/CMakeLists.txt || git clone https://github.com/feelpp/nlopt.git feelpp/contrib/nlopt
+
+ # error: no template named 'unordered_set' in namespace 'std'
+ sed -i "40i#include <unordered_set>" feelpp/feel/feelmesh/filters.hpp
}
build() {
- cd $pkgbase-$pkgver
+ cd $pkgbase-${pkgver/_/-}
mkdir -p build && cd build
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -30,28 +41,19 @@ build() {
-DCMAKE_C_COMPILER=/usr/bin/clang \
-DCMAKE_CXX_COMPILER=/usr/bin/clang++ \
-DPETSC_DIR=/opt/petsc/linux-c-opt/ \
- -DFEELPP_ENABLE_OPENTURNS=OFF \
- -DFEELPP_ENABLE_VTK=OFF \
+ -DFEELPP_MINIMAL_CONFIGURATION=ON \
+ -DFEELPP_MINIMAL_BUILD=ON \
-DFEELPP_ENABLE_QUICKSTART=OFF \
- -DFEELPP_ENABLE_TOOLBOXES=OFF \
- -DFEELPP_ENABLE_DOCUMENTATION=OFF \
- -DFEELPP_ENABLE_BENCHMARKS=OFF \
- -DFEELPP_ENABLE_APPLICATIONS=OFF \
- -DFEELPP_ENABLE_TESTS=OFF \
- -DFEELPP_ENABLE_RESEARCH=OFF \
+ -DFEELPP_ENABLE_PYFEELPP_LIBFEELPP=OFF \
-DBUILD_GUILE=OFF -DBUILD_PYTHON=OFF \
..
# templates take a lot of ram
- make feelpp -j1
- make
+ make -j1
}
package() {
- cd $pkgbase-$pkgver/build
+ cd $pkgbase-${pkgver/_/-}/build
make DESTDIR="$pkgdir/" install
- rm -r "$pkgdir"/usr/include/boost
- rm "$pkgdir/"usr/lib/pkgconfig/hana.pc
- rm "$pkgdir"/usr/bin/ginsh
- rm -r "$pkgdir"/home
+ rm "$pkgdir"/usr/bin/{gflags_completions.sh,ginsh}
}