summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--fix-autostart-path.diff13
3 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7f5ead70c81..4a64536c9687 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ferdi-git
pkgdesc = A messaging browser that allows you to combine your favorite messaging services into one application - git version
pkgver = 5.5.0.gm.2.r26.gea4e0c87
- pkgrel = 1
+ pkgrel = 2
url = https://getferdi.com
arch = x86_64
arch = i686
@@ -23,6 +23,6 @@ pkgbase = ferdi-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 91cc72f00db20e1bded69d08578e6ae9fdc89a4582ee8f6d29697b0233d7d095
+ sha256sums = 9782d1bfbf0379ef1e7afb9f43b6c35ee2331b142c7705c336cab269e18648cb
pkgname = ferdi-git
diff --git a/PKGBUILD b/PKGBUILD
index d4ef2f6e7bc7..493378a02c16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_pkgname='ferdi'
pkgname="$_pkgname-git"
pkgver='5.5.0.gm.2.r26.gea4e0c87'
-pkgrel='1'
+pkgrel='2'
pkgdesc='A messaging browser that allows you to combine your favorite messaging services into one application - git version'
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
url="https://get$_pkgname.com"
@@ -24,7 +24,7 @@ source=(
sha256sums=('SKIP'
'SKIP'
'SKIP'
- '91cc72f00db20e1bded69d08578e6ae9fdc89a4582ee8f6d29697b0233d7d095')
+ '9782d1bfbf0379ef1e7afb9f43b6c35ee2331b142c7705c336cab269e18648cb')
_sourcedirectory="$pkgname"
_homedirectory="$pkgname-home"
diff --git a/fix-autostart-path.diff b/fix-autostart-path.diff
index 8ba8fabdd8ad..fef1013e4401 100644
--- a/fix-autostart-path.diff
+++ b/fix-autostart-path.diff
@@ -1,12 +1,13 @@
diff --git a/src/stores/AppStore.js b/src/stores/AppStore.js
-index 36e6efd4..c6e4a32c 100644
+index 153fdb2c..96a18f37 100644
--- a/src/stores/AppStore.js
+++ b/src/stores/AppStore.js
-@@ -35,6 +35,7 @@ const mainWindow = remote.getCurrentWindow();
+@@ -34,7 +34,7 @@ const mainWindow = remote.getCurrentWindow();
+
const defaultLocale = DEFAULT_APP_SETTINGS.locale;
+
+-const executablePath = isMac ? remote.process.execPath : process.execPath;
++const executablePath = '/usr/bin/ferdi';
const autoLauncher = new AutoLaunch({
name: 'Ferdi',
-+ path: '/usr/bin/ferdi',
- });
-
- const CATALINA_NOTIFICATION_HACK_KEY = '_temp_askedForCatalinaNotificationPermissions';
+ path: executablePath,