summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD2
-rwxr-xr-xupdate.sh1
3 files changed, 10 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea22af4b86d4..c3475f217e3e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,14 +7,20 @@ pkgbase = ferdium-bin
arch = armv7l
arch = arm64
license = Apache
+ depends = nss
+ depends = atk
+ depends = at-spi2-atk
+ depends = libcups
+ depends = libdrm
+ depends = gdk-pixbuf2
+ depends = gtk3
+ depends = alsa-lib
depends = c-ares
depends = ffmpeg
- depends = gtk3
depends = libevent
depends = libxkbfile
depends = libxslt
depends = minizip
- depends = nss
depends = re2
depends = snappy
provides = ferdium
diff --git a/PKGBUILD b/PKGBUILD
index 2560f3213e09..4e8ab015d1d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ pkgdesc='A messaging browser that allows you to combine your favorite messaging
arch=('x86_64' 'armv7l' 'arm64')
url="https://$_pkgname.org"
license=('Apache')
-depends=('c-ares' 'ffmpeg' 'gtk3' 'libevent' 'libxkbfile' 'libxslt' 'minizip' 'nss' 're2' 'snappy')
+depends=('nss' 'atk' 'at-spi2-atk' 'libcups' 'libdrm' 'gdk-pixbuf2' 'gtk3' 'alsa-lib' 'c-ares' 'ffmpeg' 'libevent' 'libxkbfile' 'libxslt' 'minizip' 're2' 'snappy')
provides=("$_pkgname")
conflicts=("$_pkgname")
_releaseurl="https://github.com/$_pkgname/$_pkgname-app/releases/download/v$pkgverorg"
diff --git a/update.sh b/update.sh
index fb90a8a38f29..0ccb722a84f2 100755
--- a/update.sh
+++ b/update.sh
@@ -2,6 +2,7 @@
set -e
+rm -rf ferdium-bin-*.pkg.tar.zst
makepkg
makepkg --printsrcinfo > .SRCINFO
newversion=$(grep pkgver .SRCINFO | awk -F= '{print $2}' | sed -e 's/ //g')