summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xbuild.sh5
-rwxr-xr-xdockerscript.sh5
-rwxr-xr-xupdate.sh5
3 files changed, 15 insertions, 0 deletions
diff --git a/build.sh b/build.sh
index cc5e00288c26..4635b51c9ed3 100755
--- a/build.sh
+++ b/build.sh
@@ -1,5 +1,10 @@
#!/usr/bin/env bash
+#
+# This script is used to test AUR builds locally in a clean Arch Linux Docker container.
+# It is not used in the AUR builds in any way, and is only for debugging purposes.
+#
+
set -e
docker run --rm -v $(pwd):/tmp/output -v $(pwd)/dockerscript.sh:/root/dockerscript.sh archlinux:base-devel /bin/bash /root/dockerscript.sh
diff --git a/dockerscript.sh b/dockerscript.sh
index d2feee8ab9ff..e97c50ca4623 100755
--- a/dockerscript.sh
+++ b/dockerscript.sh
@@ -1,5 +1,10 @@
#!/usr/bin/env bash
+#
+# This script is called by build.sh and actually does the AUR build inside a Docker container.
+# It is not used in the AUR builds in any way, and is only for debugging purposes.
+#
+
set -e
pacman -Sy --noconfirm
diff --git a/update.sh b/update.sh
index 0ccb722a84f2..c3f4bfe1c9a6 100755
--- a/update.sh
+++ b/update.sh
@@ -1,5 +1,10 @@
#!/usr/bin/env bash
+#
+# This script is used to semi-automatically run a build and update the PKGBUILD file locally.
+# It is not used in the AUR builds in any way, and is only for manual releasing purposes.
+#
+
set -e
rm -rf ferdium-bin-*.pkg.tar.zst